<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<title>Year in Review: R. Thomas, J. Thomas, D. Thompson, M. Thompson, and Tye &raquo;</title>
<meta name="viewport" content="width=device-width, initial-scale=1" />

<!-- This site is optimized with the Yoast SEO plugin v4.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Reviewing New York Giants DT Robert Thomas, LB J.T. Thomas III, S Darian Thompson, S Mykkele Thompson and TE Will Tye."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://insidefootball.com/2017/02/year-review-r-thomas-j-thomas-d-thompson-m-thompson-tye/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Year in Review: R. Thomas, J. Thomas, D. Thompson, M. Thompson, and Tye &raquo;" />
<meta property="og:description" content="Reviewing New York Giants DT Robert Thomas, LB J.T. Thomas III, S Darian Thompson, S Mykkele Thompson and TE Will Tye." />
<meta property="og:url" content="https://insidefootball.com/2017/02/year-review-r-thomas-j-thomas-d-thompson-m-thompson-tye/" />
<meta property="og:site_name" content="Inside Football LLC" />
<meta property="article:tag" content="Darian Thompson" />
<meta property="article:tag" content="j.t thomas" />
<meta property="article:tag" content="Mykkele Thompson" />
<meta property="article:tag" content="Robert Thomas" />
<meta property="article:tag" content="Will Tye" />
<meta property="article:section" content="Analysis" />
<meta property="article:published_time" content="2017-02-01T08:00:42-05:00" />
<meta property="article:modified_time" content="2017-01-31T23:12:34-05:00" />
<meta property="og:updated_time" content="2017-01-31T23:12:34-05:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Reviewing New York Giants DT Robert Thomas, LB J.T. Thomas III, S Darian Thompson, S Mykkele Thompson and TE Will Tye." />
<meta name="twitter:title" content="Year in Review: R. Thomas, J. Thomas, D. Thompson, M. Thompson, and Tye &raquo;" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Inside Football LLC &raquo; Feed" href="https://insidefootball.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Inside Football LLC &raquo; Comments Feed" href="https://insidefootball.com/comments/feed/" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="alternate" type="application/rss+xml" title="Inside Football LLC &raquo; Year in Review: R. Thomas, J. Thomas, D. Thompson, M. Thompson, and Tye Comments Feed" href="https://insidefootball.com/2017/02/year-review-r-thomas-j-thomas-d-thompson-m-thompson-tye/feed/" />
<link rel="pingback" href="https://insidefootball.com/xmlrpc.php" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/insidefootball.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='opinionstage-style-css'  href='https://insidefootball.com/wp-content/plugins/social-polls-by-opinionstage/opinionstage-style-common.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='opinionstage-font-style-css'  href='https://insidefootball.com/wp-content/plugins/social-polls-by-opinionstage/opinionstage-font.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='pricingtable_style-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/css/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='pricingtable_style_common-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/css/style-common.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/css/animate.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-color-picker-css'  href='https://insidefootball.com/wp-admin/css/color-picker.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='ParaAdmin-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/ParaAdmin/css/ParaAdmin.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='pricingtable-style-flat-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/themes/flat/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='pricingtable-style-rounded-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/themes/rounded/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='pricingtable-style-sonnet-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/themes/sonnet/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='Raleway-css'  href='http://fonts.googleapis.com/css?family=Raleway%3A900&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='ahronbd-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/fonts/ahronbd.ttf?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='Bellerose-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/fonts/Bellerose.ttf?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='pricingtable_style-admin-css'  href='https://insidefootball.com/wp-content/plugins/pricingtable/css/style-admin.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpsc-thickbox-css'  href='https://insidefootball.com/wp-content/plugins/wp-e-commerce/wpsc-core/js/thickbox.css?ver=3.11.4.6fd2d64' type='text/css' media='all' />
<link rel='stylesheet' id='wpsc-theme-css-css'  href='https://insidefootball.com/wp-content/plugins/wp-e-commerce/wpsc-components/theme-engine-v1/templates/wpsc-default.css?ver=3.11.4.6fd2d64' type='text/css' media='all' />
<style id='wpsc-theme-css-inline-css' type='text/css'>

		/*
		* Default View Styling
		*/
		div.default_product_display div.textcol{
			margin-left: 158px !important;
			min-height: 148px;
			_height: 148px;
		}

		div.default_product_display  div.textcol div.imagecol{
			position:absolute;
			top:0px;
			left: 0px;
			margin-left: -158px !important;
		}

		div.default_product_display  div.textcol div.imagecol a img {
			width: 148px;
			height: 148px;
		}

		.wpsc_category_grid_item  {
			display:block;
			float:left;
			width: 148px;
			height: 148px;
		}
		.wpsc_category_grid_item  span{
			position:relative;
			top:16.222222222222px;
		}
		div.default_product_display div.item_no_image a  {
			width: 146px;
		}

		div.default_product_display .imagecol img.no-image, #content div.default_product_display .imagecol img.no-image {
			width: 148px;
			height: 148px;
        }

		
		/*
		* Single View Styling
		*/

		div.single_product_display div.item_no_image  {
			width: 146px;
			height: 146px;
		}
		div.single_product_display div.item_no_image a  {
			width: 146px;
		}

		div.single_product_display div.textcol{
			margin-left: 158px !important;
			min-height: 148px;
			_height: 148px;
		}


		div.single_product_display  div.textcol div.imagecol{
			position:absolute;

			margin-left: -158px !important;
		}

		div.single_product_display  div.textcol div.imagecol a img {
			width: 148px;
			height: 148px;
		}

	div#categorydisplay{
		display: block;
	}

	div#branddisplay{
		display: none;
	}

</style>
<link rel='stylesheet' id='wpsc-theme-css-compatibility-css'  href='https://insidefootball.com/wp-content/plugins/wp-e-commerce/wpsc-components/theme-engine-v1/templates/compatibility.css?ver=3.11.4.6fd2d64' type='text/css' media='all' />
<link rel='stylesheet' id='monstroid-first-screen-css'  href='https://insidefootball.com/wp-content/themes/monstroid/assets/css/first.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-blog-style-css'  href='https://insidefootball.com/wp-content/plugins/cherry-blog-layouts/public/assets/css/style.css?ver=1.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-portfolio-css'  href='https://insidefootball.com/wp-content/plugins/cherry-portfolio/public/assets/css/style.css?ver=1.0.4.8' type='text/css' media='all' />
<link rel='stylesheet' id='slider-pro-style-css'  href='https://insidefootball.com/wp-content/plugins/cherry-simple-slider/public/assets/css/slider-pro.css?ver=1.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-slider-style-css'  href='https://insidefootball.com/wp-content/plugins/cherry-simple-slider/public/assets/css/style.css?ver=1.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-social-flaticon-css'  href='https://insidefootball.com/wp-content/plugins/cherry-social-master/public/assets/fonts/flaticon.min.css?ver=1.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-social-css'  href='https://insidefootball.com/wp-content/plugins/cherry-social-master/public/assets/css/public.css?ver=1.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-testimonials-css'  href='https://insidefootball.com/wp-content/plugins/cherry-testimonials/public/assets/css/style.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='edd-styles-css'  href='https://insidefootball.com/wp-content/plugins/easy-digital-downloads/templates/edd.min.css?ver=2.6.17' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://insidefootball.com/wp-includes/css/dashicons.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css'  href='https://insidefootball.com/wp-includes/css/jquery-ui-dialog.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css-css'  href='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/css/jquery-ui.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-structure-css-css'  href='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/css/jquery-ui.structure.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-theme-css-css'  href='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/css/jquery-ui.theme.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpce_bootstrap-css'  href='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/js/bootstrap/css/bootstrap.css?version=8.0.0&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpce_display_ticket-css'  href='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/css/display_ticket.css?version=8.0.0&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpce_public-css'  href='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/css/public.css?version=8.0.0&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpce_admin-css'  href='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/css/jquery-ui.css?version=8.0.0&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css?ver=4.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='swiper-css'  href='https://insidefootball.com/wp-content/plugins/cherry-shortcodes/assets/css/swiper.css?ver=1.0.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://insidefootball.com/wp-content/themes/cherryframework4/lib/assets/css/magnific-popup.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-shortcodes-all-css'  href='https://insidefootball.com/wp-content/plugins/cherry-shortcodes/assets/css/shortcodes.css?ver=1.0.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-charts-css'  href='https://insidefootball.com/wp-content/plugins/cherry-charts/assets/public/css/cherry-charts.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='monstroid-grid-base-css'  href='https://insidefootball.com/wp-content/themes/monstroid/assets/css/grid-base.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='monstroid-grid-responsive-css'  href='https://insidefootball.com/wp-content/themes/monstroid/assets/css/grid-responsive.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css'  href='https://insidefootball.com/wp-content/themes/cherryframework4/lib/assets/css/slick.css?ver=1.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='monstroid-main-css'  href='https://insidefootball.com/wp-content/themes/monstroid/assets/css/main.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='monstroid-main-responsive-css'  href='https://insidefootball.com/wp-content/themes/monstroid/assets/css/main-responsive.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='cherryframework4-add-ons-css'  href='https://insidefootball.com/wp-content/themes/cherryframework4/lib/assets/css/add-ons.css?ver=4.0.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='monstroid-style-css'  href='https://insidefootball.com/wp-content/themes/monstroid/style.css?ver=1.1.2' type='text/css' media='all' />
<style id='monstroid-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='cherry-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A900%2Cregular%2C700%7COpen+Sans%3A700%7CArial%2C+Helvetica%3A700%7CAbril+Fatface%3Aitalic&#038;subset=latin%2Clatin-ext&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-mega-menu-css'  href='https://insidefootball.com/wp-content/plugins/cherry-mega-menu/public/assets/css/style.css?ver=1.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://insidefootball.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-grid-css'  href='https://insidefootball.com/wp-content/plugins/cherry-grid/assets/css/style.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-rank-css'  href='https://insidefootball.com/wp-content/plugins/cherry-rank/public/assets/css/style.css?ver=1.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-services-css'  href='https://insidefootball.com/wp-content/plugins/cherry-services/public/assets/css/style.css?ver=1.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-team-css'  href='https://insidefootball.com/wp-content/plugins/cherry-team/public/assets/css/style.css?ver=1.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='cherry-style-switcher-css'  href='https://insidefootball.com/wp-content/plugins/cherry-style-switcher/includes/assets/css/style.css?ver=1.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://insidefootball.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='mpce-theme-css'  href='https://insidefootball.com/wp-content/plugins/motopress-content-editor/includes/css/theme.min.css?ver=2.1.1' type='text/css' media='all' />
<style id='mpce-theme-inline-css' type='text/css'>
.mp-row-fixed-width {max-width:1170px;}
</style>
<link rel='stylesheet' id='monstroid-mpce-css'  href='https://insidefootball.com/wp-content/themes/monstroid/assets/css/moto-margins.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://insidefootball.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.2' type='text/css' media='all' />
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pricingtable_ajax = {"pricingtable_ajaxurl":"https:\/\/insidefootball.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/pricingtable/js/scripts.js?ver=4.7.2'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/pricingtable/ParaAdmin/js/ParaAdmin.js?ver=4.7.2'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-e-commerce/wpsc-core/js/wp-e-commerce.js?ver=3.11.4.6fd2d64'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-e-commerce/wpsc-admin/js/jquery.livequery.js?ver=1.0.3'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-e-commerce/wpsc-core/js/user.js?ver=3.11.46fd2d64'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-e-commerce/wpsc-core/js/thickbox.js?ver=Instinct_e-commerce'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var edd_scripts = {"ajaxurl":"https:\/\/insidefootball.com\/wp-admin\/admin-ajax.php","position_in_cart":"","has_purchase_links":"","already_in_cart_message":"You have already added this item to your cart","empty_cart_message":"Your cart is empty","loading":"Loading","select_option":"Please select an option","ajax_loader":"\/wp-content\/plugins\/easy-digital-downloads\/assets\/images\/loading.gif","is_checkout":"0","default_gateway":"paypal","redirect_to_checkout":"0","checkout_page":"","permalinks":"1","quantities_enabled":"","taxes_enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/easy-digital-downloads/assets/js/edd-ajax.min.js?ver=2.6.17'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/js/bootstrap/js/bootstrap.min.js?version=8.0.0&#038;ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var display_ticket_data = {"wpsp_ajax_url":"https:\/\/insidefootball.com\/wp-admin\/admin-ajax.php","wpsp_site_url":"https:\/\/insidefootball.com","plugin_url":"https:\/\/insidefootball.com\/wp-content\/plugins\/wp-support-plus-responsive-ticket-system\/","plugin_dir":"\/home\/content\/p3pnexwpnas04_data02\/90\/3144590\/html\/wp-content\/plugins\/wp-support-plus-responsive-ticket-system\/","user_logged_in":"0","shortly_get_back":"Thank You. We will shortly get back to you on your given mail address!","insert_all_required":"Please Enter all required fields","reply_not_empty":"Reply can not be empty!","sure_to_delete":"Are you sure to delete this ticket?","username_or_password_missing":"Username or Password missing!!!","can_not_undone":"Can not be undone","reply_ticket_position":"1","wpsp_shortcode_used_in":"0","enable_accordion":"1","ckeditor_enable_for_guest":"1","ckeditor_enable_for_loggedin":"1","sure_to_close_status":"Are you sure?","close_status_succes":"Close Ticket ID:","display_tab":"1","Not_valid_email_address":"Please enter valid email address!","not_applicable":"Not Applicable","guest_ticket_redirect":"0","guest_ticket_redirect_url":"","wpsp_redirect_after_ticket_update":"1","sure_to_submit_ticket":"Are you sure to submit?","sure_to_submit_note":"Are you sure to add note?","label_done":"done","label_uploading":"uploading...","wait_until_upload":"Uploading attachment, please wait!","wpspAttachMaxFileSize":"20","wpspAttachFileSizeExeeded":"File Size limit exceeded! Allowed limit: 20MB","wpspRemoveAttachment":"Remove","reset_form":"Reset form data??","wpspAttachment_bc":"#1aaf1c","wpspAttachment_pc":"#ff0000","prove_human":"Please prove you are a human!"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/js/public.js?version=8.0.0&#038;ver=4.7.2'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/js/public_create_ticket.js?version=8.0.0&#038;ver=4.7.2'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/lib/ckeditor/ckeditor.js?version=8.0.0&#038;ver=4.7.2'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/lib/ckeditor/adapters/jquery.js?version=8.0.0&#038;ver=4.7.2'></script>
<link rel='https://api.w.org/' href='https://insidefootball.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://insidefootball.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://insidefootball.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='https://wp.me/p76yCb-3aT' />
<link rel="alternate" type="application/json+oembed" href="https://insidefootball.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://insidefootball.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F&#038;format=xml" />
<meta name="generator" content="Easy Digital Downloads v2.6.17" />
	<script type="text/javascript">
		MPSLCore = {
			'path': "https://insidefootball.com/wp-content/plugins/motopress-slider/motoslider_core/",
			'version': "2.0.0"
		};
	</script>
<style type='text/css'></style>			<script type="text/javascript">
                            var front_custom_filters='';
                            var front_custom_field_keys="";
			</script>
		<link rel='alternate' type='application/rss+xml' title='Inside Football LLC Product List RSS' href='https://insidefootball.com?wpsc_action=rss'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://i2.wp.com/insidefootball.com/wp-content/uploads/2016/01/cropped-IFlogopart.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/insidefootball.com/wp-content/uploads/2016/01/cropped-IFlogopart.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/insidefootball.com/wp-content/uploads/2016/01/cropped-IFlogopart.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/insidefootball.com/wp-content/uploads/2016/01/cropped-IFlogopart.jpg?fit=270%2C270&#038;ssl=1" />
</head>
<body class="post-template-default single single-post postid-12207 single-format-standard cherry-responsive cherry-with-sidebar group-blog" dir="ltr">

	
	<div id="site-wrapper" class="hfeed site">

		<header id="header" class="site-header wide" role="banner">
		<div id="static-area-header-top" class="header-top static-area"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-4 col-lg-4 static-header-logo vertical-middle"><div class="site-branding"><div class="logo-tagline-wrap"><h2 class="site-title image-logo"><a href="https://insidefootball.com/" rel="home"><img src="https://insidefootball.com/wp-content/uploads/2016/01/inside-football-1000-e1452301423928.gif" alt="Inside Football LLC"></a></h2></div><div class="menu-trigger"><button class="hamburger"><span>toggle menu</span></button></div> </div></div><div class="col-xs-12 col-sm-12 col-md-8 col-lg-8 static-header-menu vertical-middle">
	<!-- Primary navigation -->
	<nav class="menu-primary menu" role="navigation" id="menu-primary">

		<label class="cherry-mega-menu-mobile-trigger" for="trigger-menu-primary-items">Menu</label><input class="cherry-mega-menu-mobile-trigger-box" id="trigger-menu-primary-items" type="checkbox"><ul id="menu-primary-items" class="menu-items cherry-mega-no-js cherry-mega-menu mega-menu-direction-horizontal total-columns-12" data-event="hover" data-effect="fade-in" data-direction="horizontal" data-mobile-trigger="768" data-parent-selector=".container"><li id="menu-item-5002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-5002 cherry-mega-menu-top-item item-submenu-position-fullwidth cherry-mega-menu-has-children item-type-standard item-align-top-left menu-item-standard" data-hide-mobile="" data-sub-hr-position="fullwidth" data-sub-vr-position="vertical-parent" data-sub-type="standard"><a href="https://insidefootball.com/" data-title="Inside Football">Inside Football<i class="fa fa-angle-down mega-menu-arrow top-level-arrow"></i></a><div class="menu-line"></div>
<ul class="cherry-mega-menu-sub level-0 effect-fade-in simple-sub">
	<li id="menu-item-4551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4551 cherry-mega-menu-sub-item cherry-mega-menu-has-children item-type-standard item-nested-sub item-nested-sub-1 menu-item-standard"><a href="https://insidefootball.com/about-us/" data-title="About Us">About Us<i class="fa fa-angle-double-down mega-menu-arrow sub-arrow"></i></a><div class="menu-line"></div>
	<ul class="cherry-mega-menu-sub level-1 effect-fade-in simple-sub">
		<li id="menu-item-4554" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4554 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="https://insidefootball.com/faq/" data-title="FAQs">FAQs</a><div class="menu-line"></div></li>
		<li id="menu-item-4887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4887 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="https://insidefootball.com/links-resources/" data-title="Links &#038; Resources">Links &#038; Resources</a><div class="menu-line"></div></li>
		<li id="menu-item-4840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4840 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="https://insidefootball.com/privacy-policy/" data-title="Privacy Policy">Privacy Policy</a><div class="menu-line"></div></li>
		<li id="menu-item-4839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4839 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="https://insidefootball.com/terms-and-conditions/" data-title="Terms and Conditions">Terms and Conditions</a><div class="menu-line"></div></li>
	</ul>
</li>
	<li id="menu-item-5394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5394 cherry-mega-menu-sub-item cherry-mega-menu-has-children item-type-standard item-nested-sub item-nested-sub-1 menu-item-standard"><a href="http://www.dev.insidefootball.com/RS13-15.pdf" data-title="Sample Issue (PDF)">Sample Issue (PDF)<i class="fa fa-angle-right mega-menu-arrow sub-arrow"></i></a><div class="menu-line"></div>
	<ul class="cherry-mega-menu-sub level-1 effect-fade-in simple-sub">
		<li id="menu-item-5067" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5067 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="https://insidefootball.com/testimonials/" data-title="Subscriber Testimonials">Subscriber Testimonials</a><div class="menu-line"></div></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-5420" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5420 cherry-mega-menu-top-item item-submenu-position-fullwidth cherry-mega-menu-has-children item-type-standard item-align-top-left menu-item-standard" data-hide-mobile="" data-sub-hr-position="fullwidth" data-sub-vr-position="vertical-parent" data-sub-type="standard"><a href="https://insidefootball.com/home-blog/" data-title="Latest Giants Headlines">Latest Giants Headlines<i class="fa fa-angle-down mega-menu-arrow top-level-arrow"></i></a><div class="menu-line"></div>
<ul class="cherry-mega-menu-sub level-0 effect-fade-in simple-sub">
	<li id="menu-item-5013" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5013 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-1 menu-item-standard"><a href="https://insidefootball.com/5005-2/" data-title="Key Dates">Key Dates</a><div class="menu-line"></div></li>
	<li id="menu-item-4927" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4927 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-1 menu-item-standard"><a href="https://insidefootball.com/2016-giants-schedule/" data-title="2016 Giants Schedule">2016 Giants Schedule</a><div class="menu-line"></div></li>
	<li id="menu-item-5134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5134 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-1 menu-item-standard"><a href="https://insidefootball.com/coaching-staff/" data-title="Coaching Staff">Coaching Staff</a><div class="menu-line"></div></li>
	<li id="menu-item-4842" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4842 cherry-mega-menu-sub-item cherry-mega-menu-has-children item-type-standard item-nested-sub item-nested-sub-1 menu-item-standard"><a href="https://insidefootball.com/new-york-giants-roster-practice-squad-reserve-lists/" data-title="Roster &#038; Personnel">Roster &#038; Personnel<i class="fa fa-angle-right mega-menu-arrow sub-arrow"></i></a><div class="menu-line"></div>
	<ul class="cherry-mega-menu-sub level-1 effect-fade-in simple-sub">
		<li id="menu-item-4863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4863 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="https://insidefootball.com/unofficial-depth-charts-2/" data-title="Unofficial Depth Charts">Unofficial Depth Charts</a><div class="menu-line"></div></li>
		<li id="menu-item-4911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4911 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="http://www.nfl.com/teams/newyorkgiants/injuries?team=NYG" data-title="Injury Report (via NFL.com)">Injury Report (via NFL.com)</a><div class="menu-line"></div></li>
		<li id="menu-item-4910" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4910 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="http://www.giants.com/team/statistics.html" data-title="Team Stats (via Giants.com">Team Stats (via Giants.com</a><div class="menu-line"></div></li>
		<li id="menu-item-4888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4888 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-2 menu-item-standard"><a href="http://overthecap.com/salary-cap/new-york-giants" data-title="Contract/Salary Info (via Over the Cap)">Contract/Salary Info (via Over the Cap)</a><div class="menu-line"></div></li>
		<li id="menu-item-4864" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4864 cherry-mega-menu-sub-item cherry-mega-menu-has-children item-type-standard item-nested-sub item-nested-sub-2 menu-item-standard"><a href="#" data-title="Transactions">Transactions<i class="fa fa-angle-right mega-menu-arrow sub-arrow"></i></a><div class="menu-line"></div>
		<ul class="cherry-mega-menu-sub level-2 effect-fade-in simple-sub">
			<li id="menu-item-12127" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12127 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-3 menu-item-standard"><a href="https://insidefootball.com/transactions-2017/" data-title="2017">2017</a><div class="menu-line"></div></li>
			<li id="menu-item-4859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4859 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-3 menu-item-standard"><a href="https://insidefootball.com/transactions-2016/" data-title="2016">2016</a><div class="menu-line"></div></li>
			<li id="menu-item-4860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4860 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-3 menu-item-standard"><a href="https://insidefootball.com/transactions-2015/" data-title="2015">2015</a><div class="menu-line"></div></li>
			<li id="menu-item-4861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4861 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-3 menu-item-standard"><a href="https://insidefootball.com/transactions-2014/" data-title="2014">2014</a><div class="menu-line"></div></li>
			<li id="menu-item-4862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4862 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-3 menu-item-standard"><a href="https://insidefootball.com/transactions-2013/" data-title="2013">2013</a><div class="menu-line"></div></li>
		</ul>
</li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-4920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4920 cherry-mega-menu-top-item item-submenu-position-fullwidth cherry-mega-menu-has-children item-type-standard item-align-top-left menu-item-standard" data-hide-mobile="" data-sub-hr-position="fullwidth" data-sub-vr-position="vertical-parent" data-sub-type="standard"><a href="https://dev.insidefootball.com/amember/login" data-title="My Account">My Account<i class="fa fa-angle-down mega-menu-arrow top-level-arrow"></i></a><div class="menu-line"></div>
<ul class="cherry-mega-menu-sub level-0 effect-fade-in simple-sub">
	<li id="menu-item-9345" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9345 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-1 menu-item-standard"><a href="http://www.dev.insidefootball.com/" data-title="Log in to My Account">Log in to My Account</a><div class="menu-line"></div></li>
	<li id="menu-item-5391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5391 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-1 menu-item-standard"><a href="https://insidefootball.com/resetting-your-password/" data-title="Resetting Your Password">Resetting Your Password</a><div class="menu-line"></div></li>
</ul>
</li>
<li id="menu-item-10476" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10476 cherry-mega-menu-top-item item-submenu-position-fullwidth cherry-mega-menu-has-children item-type-standard item-align-top-left menu-item-standard" data-hide-mobile="" data-sub-hr-position="fullwidth" data-sub-vr-position="vertical-parent" data-sub-type="standard"><a href="https://insidefootball.com/contact-us/" data-title="Contact Us">Contact Us<i class="fa fa-angle-down mega-menu-arrow top-level-arrow"></i></a><div class="menu-line"></div>
<ul class="cherry-mega-menu-sub level-0 effect-fade-in simple-sub">
	<li id="menu-item-9460" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9460 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-1 menu-item-standard"><a href="https://insidefootball.com/official/" data-title="Ask the Official">Ask the Official</a><div class="menu-line"></div></li>
	<li id="menu-item-9461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9461 cherry-mega-menu-sub-item item-nested-sub item-nested-sub-1 menu-item-standard"><a href="https://insidefootball.com/letters-editor/" data-title="Letters to the Editor">Letters to the Editor</a><div class="menu-line"></div></li>
</ul>
</li>
<li id="magic-line-left"></li><li id="magic-line-right"></li><li class="before-menu"></li><li class="after-menu"></li></ul><label class="cherry-mega-menu-mobile-close" for="trigger-menu-primary-items">Close</label>
	</nav>

</div></div></div></div><div class="shadow"></div>
		</header>
<div id="content" class="site-content wide">
	<div class="container-fluid">

		<div class="content-sidebar-wrapper"><div id="primary" class="content-area"><main id="main" class="site-main" role="main"><article class="cherry-has-entry-date cherry-has-entry-author cherry-has-entry-comments cherry-has-entry-cats cherry-has-entry-tags clearfix post-12207 post type-post status-publish format-standard hentry category-analysis tag-darian-thompson tag-j-t-thomas tag-mykkele-thompson tag-robert-thomas tag-will-tye" id="post-12207"><div class="entry-icon"></div>
<header class="entry-header"><h4 class="entry-title">Year in Review: R. Thomas, J. Thomas, D. Thompson, M. Thompson, and Tye</h4></header>
<div class="entry-meta">
	<span class="posted-on"><time class="entry-date published" datetime="2017-02-01T08:00:42-05:00">February 1, 2017</time></span>
	<span class="author vcard">by <a href="https://insidefootball.com/author/mollydadog/" title="Posts by Patricia Traina" rel="author">Patricia Traina</a></span>
	<span class="entry-terms_wrap category_wrap"><span class="entry-terms category"><a href="https://insidefootball.com/category/analysis/" rel="tag">Analysis</a></span></span>
	
	<span><div class="meta-rank-likes" id="like-12207"><a href="#" class="meta-rank-like-this " data-post="12207">0</a></div></span>
</div>


<div class="entry-content"><h3><strong>Reviewing Robert Thomas, J.T. Thomas, Darian Thompson, Mykkele Thompson and Will Tye</strong></h3>
<h3><strong>ROBERT THOMAS, DT</strong></h3>
<h5><strong>2016 Season in Review</strong></h5>
<p>Thomas began his Giants career as a bit of a mystery man. After he was claimed off waivers from Carolina, a mystery illness kept him out of practice for more than a month. He eventually regained his health and went on to contribute in nine games as a rotational defensive tackle.</p>
<p>Thomas finished with five tackles, one sack and a tackle for a loss in limited action, showing promise as another big body capable of clogging up the middle.</p>
<h5><strong>Contract Status</strong></h5>
<p>(<a href="http://www.spotrac.com/nfl/new-york-giants/robert-thomas-15142/">via Spotrac</a>)</p>
<p>Thomas is an Exclusive Rights Free Agent.</p>
<h5><strong>2017 Outlook</strong></h5>
<p>Thomas showed enough promise to where he should be getting a tender offer to remain. It will be interesting to see what having a complete offseason to work on his knowledge of the scheme and his skill set will do for him, but based on 2016, his arrow sure does seem to be pointing up.</p>
<p><img class="wp-more-tag mce-wp-nextpart" title="Page Splitter" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="" data-wp-more="nextpart" data-mce-placeholder="1" /></p>
<h3><strong>J.T. THOMAS III, LB</strong></h3>
<h5><strong>2016 Season in Review</strong></h5>
<p>Thomas&#8217; Giants career has been a disappointment largely due to injuries.</p>
<p>This year, he started training camp on the PUP list with a hamstring injury. While he managed to overcome that, in the meantime he had lost his starting weak-side linebacker spot to Jonathan Casillas.</p>
<p>Still, the hope was that Thomas might contribute something on special teams. Alas, the injury bug struck again, this time his stay on the field was a short one. Thomas tore ligaments in his knee in Week 1 against the Cowboys, the injury ending his 2016 season.</p>
<h5><strong>Contract Status</strong></h5>
<p>(<a href="http://www.spotrac.com/nfl/new-york-giants/j.t.-thomas-7915/">via Spotrac</a>)</p>
<p>The 2017 season is the final of Thomas&#8217; three-year contract. With a $4 million cap figure on the books, the Giants can save $3 million if they cut him.</p>
<h5><strong>2017 Outlook</strong></h5>
<p>Thomas stands a very good chance of being one of the roster moves made by the Giants this month to clear salary cap space.</p>
<p><img class="wp-more-tag mce-wp-nextpart" title="Page Splitter" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="" data-wp-more="nextpart" data-mce-placeholder="1" /></p>
<h3><strong>DARIAN THOMPSON, FS</strong></h3>
<h5><strong>2016 Season in Review</strong></h5>
<p>Thompson is another young player whose NFL career is off to a shaky start due to injuries.</p>
<p>After clinching the starting free safety job early in training camp, Thompson suffered a foot sprain in Week 2 of the NFL season. He opted to rest the injury in hopes he&#8217;d be able to return, but when he tried to come back after the team&#8217;s bye week, he ended up suffering a setback at which point the decision was made to shut him down for the season.</p>
<h5><strong>Contract Status</strong></h5>
<p>(<a href="http://www.spotrac.com/nfl/new-york-giants/darian-thompson-19020/">via Spotrac</a>)</p>
<p>The second year of Thompson&#8217; 4-year rookie deal carries a $819,284 cap figure.</p>
<h5><strong>2017 Outlook</strong></h5>
<p>Thompson will get an opportunity to regain the starting free safety job in 2017.</p>
<p><img class="wp-more-tag mce-wp-nextpart" title="Page Splitter" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="" data-wp-more="nextpart" data-mce-placeholder="1" /></p>
<h3><strong>MYKKELE THOMPSON, S</strong></h3>
<h5><strong>2016 Season in Review</strong></h5>
<p>Thompson&#8217;s versatility&#8211;during the spring he saw work at both safety spots and at the slot cornerback&#8211;makes it easy to see why the Giants like him as a player.</p>
<p>However, Thompson is another player who cannot stay on the field. After losing his rookie campaign to an Achilles injury, Thompson, the team&#8217;s fifth round pick in 2015, suffered a season-ending knee injury against the Saints in Week 2.</p>
<h5><strong>Contract Status</strong></h5>
<p>(<a href="http://www.spotrac.com/nfl/new-york-giants/mykkele-thompson-16870/">via Spotrac</a>)</p>
<p>Thompson is scheduled to enter the third year of his four-year rookie contract. He&#8217;ll count for $672,216 against the 2017 salary cap.</p>
<h5><strong>2017 Outlook</strong></h5>
<p>After two straight seasons on injured reserve, Thompson is in no way a lock to remain on the roster. He is versatile, but having lost two seasons, the Giants might be better off getting a player with less of an injury history in the fold.</p>
<p><img class="wp-more-tag mce-wp-nextpart" title="Page Splitter" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="" data-wp-more="nextpart" data-mce-placeholder="1" /></p>
<h3><strong>WILL TYE, TE</strong></h3>
<h5><strong>2016 Season in Review</strong></h5>
<p>Tye is a short, sluggish, mediocre-blocking tight end who kept his starting spot in the lineup because the Giants had nobody better.</p>
<p>Tye turned out to be the best of a very below-average tight ends group. He finished third on the team with 48 receptions for 395 yards, and was both durable and reliable.</p>
<p>However, as a run blocker, Tye came up woefully short, at times just not showing the ability to get this part of the job done.</p>
<p>The other thing that isn&#8217;t in Tye&#8217;s corner is his 6-2 height, which isn&#8217;t exactly the ideal size you&#8217;d like to see at the position.  Combine that with an inability to win his battles in space, and at best, Tye is probably a No. 2 or No. 3 tight end.</p>
<h5><strong>Contract Status</strong></h5>
<p>(<a href="http://www.spotrac.com/nfl/new-york-giants/will-tye-17465/">via Spotrac</a>)</p>
<p>Tye is an exclusive rights free agent who is expected to be tendered.</p>
<h5><strong>2017 Outlook</strong></h5>
<p>Tye will get an opportunity in 2017 to be a part of the tight end group, but unless injuries wipe out the position, it&#8217;s highly unlikely Tye will be the starter next year.</p>
<div id="container_3447398"></div>
<script>
  (function () {
    var opst = document.createElement('script');
    var os_host = document.location.protocol == "https:" ? "https:" : "http:";
    opst.type = 'text/javascript';
    opst.async = true;
    opst.src = os_host + '//' + 'www.opinionstage.com/containers/3447398/embed.js';
    (document.getElementsByTagName('head')[0] ||
      document.getElementsByTagName('body')[0]).appendChild(opst);
  }());
</script>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="https://insidefootball.com/2017/02/year-review-r-thomas-j-thomas-d-thompson-m-thompson-tye/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button" href="https://insidefootball.com/2017/02/year-review-r-thomas-j-thomas-d-thompson-m-thompson-tye/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div></div>


<div class="cherry-share_wrap only-logos">
	<div id="cherry-share-btns-1" class="cherry-share-btns_wrap "><ul class="cherry-share_list clearfix"><li class="cherry-share_item facebook-item"><a class="cherry-share_link" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F&amp;t=Year+in+Review%3A+R.+Thomas%2C+J.+Thomas%2C+D.+Thompson%2C+M.+Thompson%2C+and+Tye" rel="nofollow" target="_blank" rel="nofollow" title="Share on Facebook"><i class="flaticon-facebook"></i><span class="cherry-share_label">Facebook</span></a></li><li class="cherry-share_item twitter-item"><a class="cherry-share_link" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F&amp;text=Year+in+Review%3A+R.+Thomas%2C+J.+Thomas%2C+D.+Thompson%2C+M.+Thompson%2C+and+Tye" rel="nofollow" target="_blank" rel="nofollow" title="Share on Twitter"><i class="flaticon-twitter"></i><span class="cherry-share_label">Twitter</span></a></li><li class="cherry-share_item googleplus-item"><a class="cherry-share_link" href="https://plus.google.com/share?url=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F" rel="nofollow" target="_blank" rel="nofollow" title="Share on Google+"><i class="flaticon-googleplus"></i><span class="cherry-share_label">Google+</span></a></li><li class="cherry-share_item pinterest-item"><a class="cherry-share_link" href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F&amp;description=Year+in+Review%3A+R.+Thomas%2C+J.+Thomas%2C+D.+Thompson%2C+M.+Thompson%2C+and+Tye" rel="nofollow" target="_blank" rel="nofollow" title="Share on Pinterest"><i class="flaticon-pinterest"></i><span class="cherry-share_label">Pinterest</span></a></li><li class="cherry-share_item linkedin-item"><a class="cherry-share_link" href="https://www.linkedin.com/cws/share?token&amp;isFramed=false&amp;url=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F" rel="nofollow" target="_blank" rel="nofollow" title="Share on LinkedIn"><i class="flaticon-linkedin"></i><span class="cherry-share_label">LinkedIn</span></a></li><li class="cherry-share_item tumblr-item"><a class="cherry-share_link" href="https://www.tumblr.com/share?v=3&amp;u=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F&amp;t=Year+in+Review%3A+R.+Thomas%2C+J.+Thomas%2C+D.+Thompson%2C+M.+Thompson%2C+and+Tye&amp;s" rel="nofollow" target="_blank" rel="nofollow" title="Share on Tumblr"><i class="flaticon-tumblr"></i><span class="cherry-share_label">Tumblr</span></a></li><li class="cherry-share_item stumbleupon-item"><a class="cherry-share_link" href="https://www.stumbleupon.com/submit?url=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F&amp;title=Year+in+Review%3A+R.+Thomas%2C+J.+Thomas%2C+D.+Thompson%2C+M.+Thompson%2C+and+Tye" rel="nofollow" target="_blank" rel="nofollow" title="Share on StumbleUpon"><i class="flaticon-stumbleupon"></i><span class="cherry-share_label">StumbleUpon</span></a></li><li class="cherry-share_item reddit-item"><a class="cherry-share_link" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsidefootball.com%2F2017%2F02%2Fyear-review-r-thomas-j-thomas-d-thompson-m-thompson-tye%2F&amp;title=Year+in+Review%3A+R.+Thomas%2C+J.+Thomas%2C+D.+Thompson%2C+M.+Thompson%2C+and+Tye" rel="nofollow" target="_blank" rel="nofollow" title="Share on Reddit"><i class="flaticon-reddit"></i><span class="cherry-share_label">Reddit</span></a></li></ul></div>
</div></article>	<nav class="navigation post-navigation" role="navigation">
		<div class="paging-navigation">
			<div class="nav-links">
				<div class="nav-previous"><a href="https://insidefootball.com/2017/01/year-review-sensabaugh-shepard-sheppard-skinner/" rel="prev">Year in Review: Sensabaugh, Shepard, Sheppard and Skinner</a></div>			</div>
		</div>
	</nav>
	<div class="author-bio clearfix">

<figure class="author-bio_avatar alignleft"><img alt='mollydadog' src='https://secure.gravatar.com/avatar/60f73a60647564291c699827de5ce25f?s=188&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/60f73a60647564291c699827de5ce25f?s=376&amp;d=mm&amp;r=g 2x' class='avatar avatar-188 photo' height='188' width='188' /></figure>
<h5><a href="https://insidefootball.com/author/mollydadog/" title="Posts by Patricia Traina" rel="author">Patricia Traina</a></h5>
<span class="user_position"></span>
<div class="description"></div></div><div class="related-posts"><h2 class="related-posts_title">Related Posts</h2><ul class="related-posts_list row list-unstyled"><li class="related-posts_item col-xs-12 col-sm-6 col-md-6">
<h5 class="entry-title"><a href="https://insidefootball.com/2017/01/year-review-sensabaugh-shepard-sheppard-skinner/" rel="bookmark">Year in Review: Sensabaugh, Shepard, Sheppard and Skinner</a></h5>
<div class="entry-content">Reviewing Coty Sensabaugh, Sterling Shepard, Kelvin Sheppard and Deontae Skinner COTY SENSABAUGH, CB 2016 Season in</div>
<div class="entry-meta">
	<span class="posted-on"><time class="entry-date published" datetime="2017-01-31T08:00:58-05:00">January 31, 2017</time></span>	
</div>
</li><li class="related-posts_item col-xs-12 col-sm-6 col-md-6">
<h5 class="entry-title"><a href="https://insidefootball.com/2017/01/giant-dilemma-giants-fix-offensive-line/" rel="bookmark">Giant Dilemma: How Should the Giants Fix Their Offensive Line?</a></h5>
<div class="entry-content">With only two of their five starting offensive line positions set, the New York Giants</div>
<div class="entry-meta">
	<span class="posted-on"><time class="entry-date published" datetime="2017-01-30T08:00:12-05:00">January 30, 2017</time></span>	
</div>
</li></ul></div>
<div id="disqus_thread">
    </div>

</main></div>
		<div class="cherry-sidebar-main sidebar-main widget-area" role="complementary"><aside id="cherry-shortcodes-4" class="widget cherry-shortcodes"><div class="textwidget"><a href="http://www.shop.insidefootball.com/?coupon=GOGIANTS"> <div class="icon-align center mini "><span style="" class="box-icon-wrap normal  "><div class="aligncenter"><span class="cherry-icon  "><img src="https://i0.wp.com/insidefootball.com/wp-content/uploads/2016/12/coupon-1.jpg?fit=313%2C201&#038;ssl=1" alt=""></span></div></span></div></a>
<div class="cherry-hr   hr-321"></div></div></aside><aside id="text-23" class="widget widget_text">			<div class="textwidget"><a href="https://rspnutrition.com/?athletes=1599">RSP Nutrition</a>
<p>
<p>
<p>
<a href="https://PatandEdShow.podbean.com" target="_blank">
<img style="width:297px;height:170px;border:none;" src="//d8g345wuhgd7e.cloudfront.net/site/images/top10Badges/2016/sports_and_recreation.png">
</a>


</div>
		</aside><aside id="text-22" class="widget widget_text">			<div class="textwidget"><iframe style="border: 0; overflow: hidden;" frameBorder="0" scrolling="no" src="//widget.ticketmonster.com/widgets/performer-widget.php?affid=19235&performers=2516&width=300&height=250&headline=Cheap%20Tickets!&template=football1&headlineFontSize=24&bgColor=ffffff" width="300" height="250"></iframe></div>
		</aside><aside id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://insidefootball.com/" >
	<div><label class="screen-reader-text" for="s">Search for:</label>
	<input placeholder="Search" type="text" value="" name="s" id="s" />
	<button type="submit" class="search-submit">Search</button>
	</div>
	</form></aside><aside id="text-16" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Ad-01 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7201922328396792"
     data-ad-slot="1716271863"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="text-12" class="widget widget_text">			<div class="textwidget"><iframe src="https://www.speakpipe.com/widget/inline/n0ouyb55f7z35nn9sog3015jiri6k0yk" frameborder="0" width="100%" height="180px"></iframe>
</div>
		</aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><iframe src="https://widgets.itunes.apple.com/widget.html?c=us&brc=FFFFFF&blc=FFFFFF&trc=FFFFFF&tlc=FFFFFF&d=Patricia Traina and Ed Valentine talk all things New York Giants.&t=Big Blue Chat with Pat and Ed&m=podcast&e=podcast&w=250&h=300&ids=994398056&wt=playlist&partnerId=&affiliate_id=&at=&ct=" frameborder=0 style="overflow-x:hidden;overflow-y:hidden;width:250px;height: 300px;border:0px"></iframe></div>
		</aside><aside id="wpcom_social_media_icons_widget-2" class="widget widget_wpcom_social_media_icons_widget"><h5 class="widget-title">Follow Us on Social Media</h5><ul><li><a href="https://www.facebook.com/PattiTraina/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View PattiTraina&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/@Patricia_Traina/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View @Patricia_Traina&#8217;s profile on Twitter</span></a></li><li><a href="https://instagram.com/The_Sports_Scribe/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View The_Sports_Scribe&#8217;s profile on Instagram</span></a></li></ul></aside></div></div>		
	</div>
</div>

<footer id="footer" class="site-footer wide" role="contentinfo"><div id="totop"><a id="totopLink" href="javascript:void(0)"><i class="fa fa-chevron-up color-white"></i></a></div><div id="static-area-footer-top" class="footer-top static-area"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-12 col-lg-12 static-footer-sidebars"><div class='row'><div class="col-xs-12 col-sm-3"><div class="sidebar-footer-1 widget-area" role="complementary"><aside id="text-4" class="widget widget_text">			<div class="textwidget">Inside Football is a fully accredited, independent media organization that is neither sponsored by nor affiliated with the New York Football Giants or National Football League. Your use of this website constitutes your have read and agree to the terms and conditioned outlined herein under ABOUT>TERMS AND CONDITIONS.</div>
		</aside></div></div><div class="col-xs-12 col-sm-3"><div class="sidebar-footer-2 widget-area" role="complementary"><aside id="nav_menu-9" class="widget widget_nav_menu"><h5 class="widget-title">INSIDE FOOTBALL</h5><div class="menu-footer-about-us-container"><ul id="menu-footer-about-us" class="menu"><li id="menu-item-4771" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4771"><a href="https://insidefootball.com/about-us/">About Us</a></li>
<li id="menu-item-4774" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4774"><a href="https://insidefootball.com/team/">Meet Our Team</a></li>
<li id="menu-item-4775" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4775"><a href="https://insidefootball.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-5548" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5548"><a href="https://insidefootball.com/faq/">FAQs</a></li>
<li id="menu-item-5549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5549"><a href="https://insidefootball.com/subscription-options/">Subscription Options</a></li>
<li id="menu-item-5550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5550"><a href="https://insidefootball.com/testimonials/">Reader Testimonials</a></li>
</ul></div></aside></div></div><div class="col-xs-12 col-sm-3"><div class="sidebar-footer-3 widget-area" role="complementary"><aside id="nav_menu-10" class="widget widget_nav_menu"><h5 class="widget-title">HELP &#038; SUPPORT</h5><div class="menu-footer-support-container"><ul id="menu-footer-support" class="menu"><li id="menu-item-9346" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9346"><a href="https://dev.insidefootball.com/amember/login">Subscriber Login</a></li>
<li id="menu-item-5545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5545"><a href="https://insidefootball.com/resetting-your-password/">Resetting Your Password</a></li>
<li id="menu-item-5551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5551"><a href="https://insidefootball.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-5543" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5543"><a href="https://insidefootball.com/how-to-redeem-offer-codes-at-inside-footballs-subscription-shop/">Redeeming Coupons</a></li>
<li id="menu-item-4776" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4776"><a href="https://insidefootball.com/contact-us/">Contact Us</a></li>
</ul></div></aside></div></div><div class="col-xs-12 col-sm-3"><div class="sidebar-footer-4 widget-area" role="complementary"><aside id="cherry-twitter-timeline-3" class="widget cherry-twitter-timeline-class">
<a class="twitter-timeline"
	data-widget-id="685644144660901888"
	data-theme="light"
	data-link-color="#"
	data-border-color="#"
	data-tweet-limit="3"
	data-chrome="nofooter transparent"
	height="400">
</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></aside></div></div></div></div></div></div></div><div id="static-area-footer-bottom" class="footer-bottom static-area"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-4 col-lg-4 static-footer-info"><div class="site-info">©2007-2016 Inside Football LLC. Content may not be reproduced without express written consent from the Publisher. NFL and team logos are registered trademarks, and are used under the terms of the annual NFL media credential notice.</div></div></div></div></div></footer>
	</div><!--site-wrapper-->


<div id="wpsp_front_popup" onclick="wpsp_close_front_popup();" style="display: none;"></div>
<div id="wpsp_front_popup_inner" style="display: none;">
    <div id="wpsp_front_popup_blank"></div>
    <div id="wpsp_front_popup_body" style="display: none;"></div>
</div>
<img id="wpsp_front_popup_close_btn" onclick="wpsp_close_front_popup();" style="display: none;" src="https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/images/close_btn.png"/>
<img id="wpsp_front_popup_loading_img" style="display: none;" src="https://insidefootball.com/wp-content/plugins/wp-support-plus-responsive-ticket-system/asset/images/ajax-loader@2x.gif?ver=8.0.0"/>	<div style="display:none">
	<div class="grofile-hash-map-60f73a60647564291c699827de5ce25f">
	</div>
	</div>
	<div id="sharing_email" style="display: none;">
		<form action="/2017/02/year-review-r-thomas-j-thomas-d-thompson-m-thompson-tye/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://insidefootball.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<style type="text/css">.hr-321{height:3px;margin-top:20px;margin-bottom:20px;background-color:#000000;}</style><style id="motopress-ce-private-styles" data-posts="" type="text/css"></style><link rel='stylesheet' id='genericons-css'  href='https://insidefootball.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wp_load_style = {"0":"opinionstage-style.css","1":"opinionstage-font-style.css","2":"pricingtable_style.css","3":"pricingtable_style_common.css","4":"animate.css","5":"wp-color-picker.css","6":"ParaAdmin.css","7":"pricingtable-style-flat.css","8":"pricingtable-style-rounded.css","9":"pricingtable-style-sonnet.css","10":"Raleway.css","11":"ahronbd.css","12":"Bellerose.css","13":"pricingtable_style-admin.css","14":"wpsc-thickbox.css","15":"wpsc-theme-css.css","16":"wpsc-theme-css-compatibility.css","17":"monstroid-first-screen.css","18":"cherry-blog-style.css","19":"cherry-portfolio.css","20":"slider-pro-style.css","21":"cherry-slider-style.css","22":"cherry-social.css","23":"cherry-testimonials.css","24":"edd-styles.css","25":"wp-jquery-ui-dialog.css","26":"jquery-ui-css.css","27":"jquery-ui-structure-css.css","28":"jquery-ui-theme-css.css","29":"wpce_bootstrap.css","30":"wpce_display_ticket.css","31":"wpce_public.css","32":"wpce_admin.css","33":"font-awesome.css","34":"swiper.css","35":"magnific-popup.css","36":"cherry-shortcodes-all.css","37":"cherry-charts.css","38":"monstroid-grid-base.css","39":"monstroid-grid-responsive.css","40":"slick.css","42":"monstroid-main.css","43":"monstroid-main-responsive.css","44":"cherryframework4-add-ons.css","45":"monstroid-style.css","46":"cherry-google-fonts.css","47":"jetpack_social_media_icons_widget.css","48":"cherry-mega-menu.css","49":"tablepress-default.css","50":"cherry-grid.css","51":"cherry-rank.css","52":"cherry-services.css","53":"cherry-team.css","54":"cherry-style-switcher.css","55":"sharedaddy.css","56":"social-logos.css","57":"mpce-theme.css","60":"monstroid-mpce.css","61":"jetpack_css.css"};
var wp_load_script = ["jquery.js","pricingtable_js.js","pricingtable_color_picker.js","ParaAdmin.js","wp-e-commerce.js","livequery.js","wp-e-commerce-legacy.js","wpsc-thickbox.js","cherry-api.js","comment-reply.js","magnific-popup.js","cherry-script.js","jetpack-photon.js","edd-ajax.js","devicepx.js","jquery-ui-core.js","jquery-ui-dialog.js","jquery-ui-accordion.js","wpce_bootstrap.js","wpce_public.js","wpce_public_create_ticket.js","wpce_ckeditor_editor.js","wpce_ckeditor_jquery_adapter.js","jquery-ui-datepicker.js","grofiles-cards.js","wpgroho.js","cherry-mega-menu.js","monstroid-script.js"];
var cherry_ajax = "9e0012c69b";
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/themes/cherryframework4/lib/assets/js/cherry-api.min.js?ver=4.0.5.2'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var su_magnific_popup = {"close":"Close (Esc)","loading":"Loading...","prev":"Previous (Left arrow key)","next":"Next (Right arrow key)","counter":"%curr% of %total%","error":"Failed to load this link. <a href=\"%url%\" target=\"_blank\"><u>Open link<\/u><\/a>."};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/themes/cherryframework4/lib/assets/js/jquery.magnific-popup.min.js?ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cherry_data = {"use_lightbox":"1"};
var sticky_data = {"selector":".site-header","args":{"correctionSelector":"#wpadminbar","listenSelector":".listenSelector","pseudo":true,"active":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/themes/cherryframework4/lib/assets/js/script.min.js?ver=4.0.5.2'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201705'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.2'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cherry_mega_menu_data = {"duration":"300"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/cherry-mega-menu/public/assets/js/min/script.min.js?ver=1.0.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/themes/monstroid/assets/js/min/theme-script.min.js?ver=1.1.2'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cherry_rank = {"ajaxurl":"https:\/\/insidefootball.com\/wp-admin\/admin-ajax.php","nonce":"b23c0cebd4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/cherry-rank/public/assets/js/min/script.min.js?ver=1.0.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.2","language":""},"disqusIdentifier":"12207 https:\/\/insidefootball.com\/?p=12207","disqusShortname":"insidefootball","disqusTitle":"Year in Review: R. Thomas, J. Thomas, D. Thompson, M. Thompson, and Tye","disqusUrl":"https:\/\/insidefootball.com\/2017\/02\/year-review-r-thomas-j-thomas-d-thompson-m-thompson-tye\/","options":{"manualSync":false},"postId":"12207"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"insidefootball"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.4.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201705.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'104997383',post:'12207',tz:'-5',srv:'insidefootball.com'} ]);
	_stq.push([ 'clickTrackerInit', '104997383', '12207' ]);
</script>
</body>
</html>