<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://insidefootball.com/xmlrpc.php" />
<title>Giants Roster Moves: 3 Signed, 3 Waived &#8211; Inside Football</title>
          <script>
            (function(d){
              var js, id = 'powr-js', ref = d.getElementsByTagName('script')[0];
              if (d.getElementById(id)) {return;}
              js = d.createElement('script'); js.id = id; js.async = true;
              js.src = '//www.powr.io/powr.js';
              js.setAttribute('powr-token','2PdKIgicsP1489427081');
              js.setAttribute('external-type','wordpress');
              ref.parentNode.insertBefore(js, ref);
            }(document));
          </script>
          <!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="ybFai74nFlZtfAEyMq-DlMquwzZxeG4QFQe3AZ7ffi4" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Inside Football &raquo; Feed" href="https://insidefootball.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Inside Football &raquo; Comments Feed" href="https://insidefootball.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Inside Football &raquo; Giants Roster Moves: 3 Signed, 3 Waived Comments Feed" href="https://insidefootball.com/archives/2685/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/insidefootball.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mpsp-custom-style-css'  href='https://insidefootball.com/wp-content/plugins/testimonial-add/css/custom_style.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='mpsp-style-css'  href='https://insidefootball.com/wp-content/plugins/testimonial-add/owl-carousel/owl.carousel.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='mpsp_theme-css'  href='https://insidefootball.com/wp-content/plugins/testimonial-add/owl-carousel/owl.theme.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='mpsp_transitions-css'  href='https://insidefootball.com/wp-content/plugins/testimonial-add/owl-carousel/owl.transitions.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='mp-theme-css'  href='https://insidefootball.com/wp-content/plugins/memberpress/css/ui/theme.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='Total_Soft_Poll-css'  href='https://insidefootball.com/wp-content/plugins/Poll/CSS/Total-Soft-Poll-Widget.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='https://insidefootball.com/wp-content/plugins/Poll/CSS/totalsoft.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='cntctfrm_form_style-css'  href='https://insidefootball.com/wp-content/plugins/contact-form-pro/css/form_style.css?ver=4.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='edd-styles-css'  href='https://insidefootball.com/wp-content/plugins/easy-digital-downloads/templates/edd.min.css?ver=2.7.9' type='text/css' media='all' />
<link rel='stylesheet' id='ez-icomoon-css'  href='https://insidefootball.com/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=1.2' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css'  href='https://insidefootball.com/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=1.2' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {background: #fff;border: 1px solid #dd0000;}div#ez-toc-container p.ez-toc-title {color: #000000;}div#ez-toc-container ul.ez-toc-list a:hover {color: #b70000;}div#ez-toc-container ul.ez-toc-list a:hover {color: #b70000;}div#ez-toc-container ul.ez-toc-list a:visited {color: #c1c1c1;}
</style>
<link rel='stylesheet' id='jps-premiusm-style-css'  href='https://insidefootball.com/wp-content/plugins/jquery-post-splitter/pro/jps-premium-styles.css?ver=2017090540' type='text/css' media='all' />
<link rel='stylesheet' id='paged-post-jquery-css'  href='https://insidefootball.com/wp-content/plugins/jquery-post-splitter/css/paged-post-jquery.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd-popup-style-css'  href='https://insidefootball.com/wp-content/plugins/event-calendar-wd/css/ecwd_popup.css?ver=5.0.92_590934e31db19' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd_font-awesome-css'  href='https://insidefootball.com/wp-content/plugins/event-calendar-wd/css/font-awesome/font-awesome.css?ver=5.0.92_590934e31db19' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd-public-css'  href='https://insidefootball.com/wp-content/plugins/event-calendar-wd/css/style.css?ver=5.0.92_590934e31db19' type='text/css' media='all' />
<link rel='stylesheet' id='mh-style-css'  href='https://insidefootball.com/wp-content/themes/mh_newsdesk/style.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://insidefootball.com/wp-content/themes/mh_newsdesk/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700%7cOswald:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://insidefootball.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='rpt-css'  href='https://insidefootball.com/wp-content/plugins/dk-pricr-responsive-pricing-table/css/rpt_style.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://insidefootball.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://insidefootball.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.9' type='text/css' media='all' />
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/testimonial-add/owl-carousel/owl.carousel.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/event-calendar-wd/js/gmap/gmap3.js?ver=5.0.92_590934e31db19'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/event-calendar-wd/js/ecwd_popup.js?ver=5.0.92_590934e31db19'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ecwd = {"ajaxurl":"https:\/\/insidefootball.com\/wp-admin\/admin-ajax.php","ajaxnonce":"e94f44ef92","loadingText":"Loading...","event_popup_title_text":"Event Details","plugin_url":"https:\/\/insidefootball.com\/wp-content\/plugins\/event-calendar-wd","gmap_type":"ROADMAP","gmap_redirect":"","gmap_key":"","gmap_style":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/event-calendar-wd/js/scripts.js?ver=5.0.92_590934e31db19'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var object = {"ajaxurl":"https:\/\/insidefootball.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/Poll/JS/Total-Soft-Poll-Widget.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var edd_scripts = {"ajaxurl":"https:\/\/insidefootball.com\/wp-admin\/admin-ajax.php","position_in_cart":"","has_purchase_links":"","already_in_cart_message":"You have already added this item to your cart","empty_cart_message":"Your cart is empty","loading":"Loading","select_option":"Please select an option","is_checkout":"0","default_gateway":"paypal","redirect_to_checkout":"0","checkout_page":"https:\/\/insidefootball.com\/checkout","permalinks":"1","quantities_enabled":"","taxes_enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/easy-digital-downloads/assets/js/edd-ajax.min.js?ver=2.7.9'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=4.7.4'></script>
<link rel='https://api.w.org/' href='https://insidefootball.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://insidefootball.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://insidefootball.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Giants Rookie Minicamp Observations' href='https://insidefootball.com/archives/2678' />
<meta name="generator" content="WordPress 4.7.4" />
<link rel="canonical" href="https://insidefootball.com/archives/2685" />
<link rel='shortlink' href='https://wp.me/p8iY27-Hj' />
<link rel="alternate" type="application/json+oembed" href="https://insidefootball.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidefootball.com%2Farchives%2F2685" />
<link rel="alternate" type="text/xml+oembed" href="https://insidefootball.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidefootball.com%2Farchives%2F2685&#038;format=xml" />
<meta name="generator" content="Easy Digital Downloads v2.7.9" />

    <style type="text/css">

	
	</style>

    

<!-- Plugin: Open external links a new window. Plugin by Kristian Risager Larsen, http://kristianrisagerlarsen.dk . Download it at http://wordpress.org/extend/plugins/open-external-links-in-a-new-window/ -->
<script type="text/javascript">//<![CDATA[
	function external_links_in_new_windows_loop() {
		if (!document.links) {
			document.links = document.getElementsByTagName('a');
		}
		var change_link = false;
		var force = 'nfl.com, overthecap.com';
		var ignore = '';

		for (var t=0; t<document.links.length; t++) {
			var all_links = document.links[t];
			change_link = false;
			
			if(document.links[t].hasAttribute('onClick') == false) {
				// forced if the address starts with http (or also https), but does not link to the current domain
				if(all_links.href.search(/^http/) != -1 && all_links.href.search('insidefootball.com') == -1) {
					// alert('Changeda '+all_links.href);
					change_link = true;
				}
					
				if(force != '' && all_links.href.search(force) != -1) {
					// forced
					// alert('force '+all_links.href);
					change_link = true;
				}
				
				if(ignore != '' && all_links.href.search(ignore) != -1) {
					// alert('ignore '+all_links.href);
					// ignored
					change_link = false;
				}

				if(change_link == true) {
					// alert('Changed '+all_links.href);
					document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
					document.links[t].removeAttribute('target');
				}
			}
		}
	}
	
	// Load
	function external_links_in_new_windows_load(func)
	{	
		var oldonload = window.onload;
		if (typeof window.onload != 'function'){
			window.onload = func;
		} else {
			window.onload = function(){
				oldonload();
				func();
			}
		}
	}

	external_links_in_new_windows_load(external_links_in_new_windows_loop);
	//]]></script>


<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style>	<style type="text/css">
    	    		.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover .pagelink { color: #010035; }
			.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination .pagelink { background: #010035; }
			blockquote, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover, textarea:hover { border-color: #010035; }
    	    				.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink, .comment-section-title { background: #e2e2e2; }
			.commentlist .depth-1, .commentlist .bypostauthor .avatar { border-color: #e2e2e2; }
    	    	    				.header-top, .header-nav ul li:hover > ul, .footer-ad-wrap, .footer-1, .footer-2, .footer-3, .footer-bottom { background: #0a0a0a; }
			.social-nav a { color: #0a0a0a; }
    	    	    		</style>
    <!--[if lt IE 9]>
<script src="https://insidefootball.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script>
<![endif]-->

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Giants Roster Moves: 3 Signed, 3 Waived" />
<meta property="og:url" content="https://insidefootball.com/archives/2685" />
<meta property="og:description" content="Giants add three tryout-players to roster following conclusion of rookie minicamp. The New York signed three players who were in this weekend&#8217;s minicamp on a tryout basis to contracts. Added …" />
<meta property="article:published_time" content="2017-05-13T21:40:17+00:00" />
<meta property="article:modified_time" content="2017-05-13T21:40:17+00:00" />
<meta property="og:site_name" content="Inside Football" />
<meta property="og:image" content="https://i1.wp.com/insidefootball.com/wp-content/uploads/2017/01/transaction.jpg?fit=500%2C334&amp;ssl=1" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="334" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@Inside Football" />
<meta name="twitter:image" content="https://i1.wp.com/insidefootball.com/wp-content/uploads/2017/01/transaction.jpg?fit=500%2C334&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@Patricia_Traina" />
<link rel="icon" href="https://i1.wp.com/insidefootball.com/wp-content/uploads/2017/01/favicon-16x16.png?fit=16%2C16&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/insidefootball.com/wp-content/uploads/2017/01/favicon-16x16.png?fit=16%2C16&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/insidefootball.com/wp-content/uploads/2017/01/favicon-16x16.png?fit=16%2C16&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/insidefootball.com/wp-content/uploads/2017/01/favicon-16x16.png?fit=16%2C16&#038;ssl=1" />
</head>
<body class="post-template-default single single-post postid-2685 single-format-standard ecwd-theme-mh_newsdesk mh-right-sb mh-loop-layout1" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div id="mh-wrapper">
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="header-wrap clearfix">
				<div class="mh-col mh-1-3 header-logo-full">
			<a href="https://insidefootball.com/" title="Inside Football" rel="home">
<div class="logo-wrap" role="banner">
<img src="https://insidefootball.com/wp-content/uploads/2017/01/cropped-fulllogo.gif" height="163" width="866" alt="Inside Football" />
</div>
</a>
		</div>
			</div>
	<div class="header-menu clearfix">
		<nav class="main-nav clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-672"><a href="https://insidefootball.com/">HOME</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a href="#">ABOUT US</a>
<ul class="sub-menu">
	<li id="menu-item-126" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-126"><a href="https://insidefootball.com/meet-our-team">Meet Our Team</a></li>
	<li id="menu-item-174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174"><a href="https://insidefootball.com/frequently-asked-questions">Frequently Asked Questions</a></li>
	<li id="menu-item-127" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127"><a href="https://insidefootball.com/insidefootball-com-website-use-terms-and-conditions">Website Use Terms and Conditions</a></li>
	<li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://insidefootball.com/inside-football-llc-web-site-privacy-policy">Web Site Privacy Policy</a></li>
</ul>
</li>
<li id="menu-item-52" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-52"><a href="#">TEAM INFO</a>
<ul class="sub-menu">
	<li id="menu-item-677" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-677"><a href="#">Game Day</a>
	<ul class="sub-menu">
		<li id="menu-item-189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="https://insidefootball.com/new-york-giants-2017-schedule">2017 Schedule</a></li>
		<li id="menu-item-190" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-190"><a href="https://insidefootball.com/broadcast-info">Broadcast Info</a></li>
		<li id="menu-item-50" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50"><a href="http://www.giants.com/team/statistics.html">Team Statistics</a></li>
		<li id="menu-item-51" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-51"><a href="http://www.nfl.com/standings?category=div">Standings (via NFL.com)</a></li>
		<li id="menu-item-181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181"><a href="https://insidefootball.com/team-contact-information">Team Contact Information</a></li>
	</ul>
</li>
	<li id="menu-item-272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-272"><a href="https://insidefootball.com/rosters">Rosters</a>
	<ul class="sub-menu">
		<li id="menu-item-298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298"><a href="https://insidefootball.com/unofficial-depth-charts">Unofficial Depth Charts</a></li>
		<li id="menu-item-55" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55"><a href="#">Transactions</a>
		<ul class="sub-menu">
			<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://insidefootball.com/2017-transactions">2017 Transactions</a></li>
			<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://insidefootball.com/2016-transactions">2016 Transactions</a></li>
			<li id="menu-item-157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-157"><a href="https://insidefootball.com/2015-transactions">2015 Transactions</a></li>
			<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://insidefootball.com/2014-transactions">2014 Transactions</a></li>
			<li id="menu-item-159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159"><a href="https://insidefootball.com/2013-transactions">2013 Transactions</a></li>
		</ul>
</li>
	</ul>
</li>
	<li id="menu-item-273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-273"><a href="https://insidefootball.com/coaching-staff">Coaching Staff</a></li>
</ul>
</li>
<li id="menu-item-105" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-105"><a href="#">CUSTOMER SERVICE</a>
<ul class="sub-menu">
	<li id="menu-item-108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108"><a href="https://insidefootball.com/technical-support-disclaimer">Technical Support Disclaimer</a></li>
	<li id="menu-item-510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-510"><a href="https://insidefootball.com/how-to-access-your-account">Logging In/Resetting Your Password</a>
	<ul class="sub-menu">
		<li id="menu-item-1636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1636"><a href="https://insidefootball.com/why-do-i-keep-getting-a-math-puzzle-when-i-try-to-sign-in">Why Do I Keep Getting a Math Puzzle When I Try to Sign In?</a></li>
		<li id="menu-item-1637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1637"><a href="https://insidefootball.com/how-do-i-know-if-im-already-logged-in">How Do I Know If I’m Already Logged In?</a></li>
	</ul>
</li>
	<li id="menu-item-509" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-509"><a href="https://insidefootball.com/understanding-your-accountsubscriptions">Your Account Dashboard</a>
	<ul class="sub-menu">
		<li id="menu-item-746" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-746"><a target="_blank" href="https://insidefootball.com/how-to-access-subscription-material-and-premium-content">Access Subscription Material/Premium Content</a></li>
	</ul>
</li>
	<li id="menu-item-508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-508"><a href="https://insidefootball.com/how-to-toggle-between-a-slide-show-vs-full-page-view">Changing How You View Posts</a></li>
	<li id="menu-item-1495" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1495"><a href="https://insidefootball.com/free-blog-post-delivery-service-signup-instructions">Free Blog Post Delivery Service Signup Instructions</a></li>
	<li id="menu-item-898" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-898"><a href="https://insidefootball.com/chatting-with-subscriber-services">Chat with Subscriber Services</a></li>
</ul>
</li>
<li id="menu-item-654" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-654"><a href="https://insidefootball.com/subscription-plans">SUBSCRIPTION INFO</a>
<ul class="sub-menu">
	<li id="menu-item-1820" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1820"><a href="http://shop.insidefootball.com/">Subscribe to Inside Football</a></li>
	<li id="menu-item-1217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1217"><a href="https://insidefootball.com/inside-football-full-sample-issue">Full Sample Issue</a></li>
	<li id="menu-item-271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271"><a href="https://insidefootball.com/subscriber-testimonials">Reader Testimonials</a></li>
</ul>
</li>
<li id="menu-item-307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-307"><a href="#">FOOTBALL RESOURCES</a>
<ul class="sub-menu">
	<li id="menu-item-788" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-788"><a href="https://insidefootball.com/blog-posts">Blog Post Archive</a></li>
	<li id="menu-item-836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-836"><a href="https://insidefootball.com/calendar-of-important-dates">Important Dates</a></li>
	<li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://insidefootball.com/related-links">Related Links &#038; Twitter Resources</a></li>
	<li id="menu-item-57" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57"><a href="http://overthecap.com/salary-cap/new-york-giants/">Contract/Salary Info (via Over the Cap)</a></li>
	<li id="menu-item-308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-308"><a href="https://insidefootball.com/salary-cap-primer-faq">Understanding the Salary Cap</a></li>
	<li id="menu-item-1034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1034"><a href="https://insidefootball.com/nfl-proposed-minimum-salary-table">NFL Proposed Minimum Salaries</a></li>
	<li id="menu-item-937" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-937"><a href="http://overthecap.com/the-basics-and-methodology-of-projecting-the-nfls-compensatory-draft-picks/">Comp Draft Pick Info (per OTC)</a></li>
	<li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://insidefootball.com/ask-the-official">Ask the Official</a></li>
</ul>
</li>
<li id="menu-item-449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-449"><a href="https://insidefootball.com/contact-us">CONTACT US</a></li>
<li id="menu-item-130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130"><a href="https://insidefootball.com/letters-to-the-editor">LETTERS TO THE EDITOR</a></li>
<li id="menu-item-676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-676"><a href="https://insidefootball.com/account">MY ACCOUNT (Login)</a>
<ul class="sub-menu">
	<li id="menu-item-789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-789"><a href="https://insidefootball.com/archives/category/premium">Subscriber Content</a></li>
</ul>
</li>
</ul></div>		</nav>
		<div class="header-sub clearfix">
							<div id="ticker" class="news-ticker mh-col mh-2-3 clearfix">
			<span class="ticker-title">
			WHAT&#039;S NEW		</span>
		<ul class="ticker-content">			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/archives/2685" title="Giants Roster Moves: 3 Signed, 3 Waived">
					<span class="ticker-item-date">May 13, 2017</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Giants Roster Moves: 3 Signed, 3 Waived</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/archives/2678" title="Giants Rookie Minicamp Observations">
					<span class="ticker-item-date">May 13, 2017</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Giants Rookie Minicamp Observations</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/archives/2670" title="Department of Defense: Middle Linebacker, Free Safety Jobs Open">
					<span class="ticker-item-date">May 12, 2017</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Department of Defense: Middle Linebacker, Free Safety Jobs Open</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/archives/2665" title="Webb, Engram Form Early Bond on Giants Offense">
					<span class="ticker-item-date">May 12, 2017</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Webb, Engram Form Early Bond on Giants Offense</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/archives/2657" title="Wayne Gallman is Hungry for Carries, Giants Cafeteria Food">
					<span class="ticker-item-date">May 12, 2017</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Wayne Gallman is Hungry for Carries, Giants Cafeteria Food</span>
				</a>
			</li>	</ul>
</div>						<aside class="mh-col mh-1-3 header-search">
				<form role="search" method="get" class="search-form" action="https://insidefootball.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</aside>
		</div>
	</div>
</header><div class="mh-section mh-group">
	<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><article id="post-2685" class="post-2685 post type-post status-publish format-standard has-post-thumbnail hentry category-transactions tag-khalid-abdullah tag-saqwan-edwards tag-trey-robinson">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Giants Roster Moves: 3 Signed, 3 Waived		</h1><div class="entry-tags clearfix"><span>TOPICS:</span><a href="https://insidefootball.com/archives/tag/khalid-abdullah" rel="tag">Khalid Abdullah</a><a href="https://insidefootball.com/archives/tag/saqwan-edwards" rel="tag">SaQwan Edwards</a><a href="https://insidefootball.com/archives/tag/trey-robinson" rel="tag">Trey Robinson</a></div>	</header><p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="https://insidefootball.com/archives/author/patriciatraina">Patricia Traina</a></span>
<span class="entry-meta-date updated">May 13, 2017</span>
</p>
	<div class="entry-content clearfix">
		<h2>Giants add three tryout-players to roster following conclusion of rookie minicamp.</h2>
<p>The New York signed three players who were in this weekend&#8217;s minicamp on a tryout basis to contracts.</p>
<p>Added were running back Khalid Abdullah, cornerback SaQwan Edwards and safety Trey Robinson.</p>
<p>Abdullah, 5-9, 211, played his college ball at James Madison, where in 48 games, he rushed 673 times for 3,678 yards (5.5 yards per carry) and 41 touchdowns, with 15 100-yard rushing games in his career, 11 as a senior. He also caught  42 balls for 283 yards, and four touchdowns.</p>
<p>Abdullah is a four-time All-American, and a  AFCA and HERO Sports First Team and STATS and AP Second Team honoree. He was voted the Most Outstanding Player in 2017 national championship game.</p>
<p>He holds JMU career records for rushing touchdowns (41), total touchdowns (45) and scoring (270), and ranks second all-time at JMU in both rushing yards (3,678) and rush attempts (673), and fourth in all-purpose yards (4,077)</p>
<p>Edwards, 6-0, 200 lbs., spent the 2015 season with the Raiders, but did not appear in any games. In 30 games for New Mexico, he logged 85 tackles (5.5 for a loss), 2.0 sacks, 3 interceptions, 13 passes defensed, and 3 fumble recoveries.</p>
<p>Prior to enrolling at New Mexico, he played one season for Blinn Junior College. A former wide receiver, Edwards was <a href="https://www.usatoday.com/story/sports/ncaaf/2014/04/30/new-mexicos-saqwan-edwards-arrested-in-rape-case/8508139/">arrested on rape allegations  </a>in April 2014, resulting in his being suspended from the team. He was  <a href="http://www.nfl.com/draft/2015/profiles/saqwan-edwards?id=2553264">reinstated in August 2014</a> after the case was dismissed.</p>
<p>Robinson, 6-1, 217 lbs., is  rookie out of Furhman, who converted to safety after starting his football career as a quarterback, where he was named named all-area, all-region, and High School Sports Report all-state during his tenure at Dorman High School.</p>
<p><a href="http://www.furmanpaladins.com/sports/m-footbl/2016-17/teamcume.htm#TEAM.IND">Last year as a senior</a>, Robinson, who describes himself as a <a href="http://www.nfldraftdiamonds.com/trey-robinson-db-furman-university/">ball-hawking free safety</a>, had one interception for the Paladins to go along with a team-leading 104 tackles, (four for a loss), seven passes defensed and one forced fumble.</p>
<p>To make room on the roster, the Giants waived cornerback Nigel Tribune, wide receiver Robert Wheelwright and running back Daryl Virgies.</p>
<p>Tribune and Wheelwright were signed as undrafted free agents at the start of this year&#8217;s minicamp; Virgies had been on the roster since January, when he signed a reserve/futures contract.</p>
<p>The Giants roster currently stands at 90.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="https://insidefootball.com/archives/2685?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://insidefootball.com/archives/2685" data-text="Giants Roster Moves: 3 Signed, 3 Waived" data-via="InsideFootball" >Tweet</a></li><li class="share-facebook"><div class="fb-share-button" data-href="https://insidefootball.com/archives/2685" data-layout="button_count"></div></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="https://insidefootball.com/archives/2685"></div></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Finsidefootball.com%2Farchives%2F2685&#038;media=https%3A%2F%2Fi1.wp.com%2Finsidefootball.com%2Fwp-content%2Fuploads%2F2017%2F01%2Ftransaction.jpg%3Ffit%3D500%252C334%26ssl%3D1&#038;description=Giants%20Roster%20Moves%3A%203%20Signed%2C%203%20Waived" data-pin-do="buttonPin" data-pin-config="beside"><img src="https://i0.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?ssl=1" data-recalc-dims="1" /></a></div></li><li class="share-tumblr"><a target="_blank" href="https://www.tumblr.com/share/link/?url=https%3A%2F%2Finsidefootball.com%2Farchives%2F2685&name=Giants%20Roster%20Moves%3A%203%20Signed%2C%203%20Waived" title="Share on Tumblr" style="display:inline-block; text-indent:-9999px; overflow:hidden; width:62px; height:20px; background:url('https://platform.tumblr.com/v1/share_2.png') top left no-repeat transparent;">Share on Tumblr</a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button" href="https://insidefootball.com/archives/2685#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-pocket"><div class="pocket_button"><a href="https://getpocket.com/save" class="pocket-btn" data-lang="en" data-save-url="https://insidefootball.com/archives/2685" data-pocket-count="horizontal" >Pocket</a></div></li><li class="share-end"></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button" href="whatsapp://send?text=Giants%20Roster%20Moves%3A%203%20Signed%2C%203%20Waived https%3A%2F%2Finsidefootball.com%2Farchives%2F2685" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-122731363-2685-59177d5129b17' data-src='//widgets.wp.com/likes/#blog_id=122731363&amp;post_id=2685&amp;origin=insidefootball.com&amp;obj_id=122731363-2685-59177d5129b17' data-name='like-post-frame-122731363-2685-59177d5129b17'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	</div>
	</article><div class="mh-share-buttons mh-group">
    <a class="mh-col mh-1-4 mh-facebook" href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://insidefootball.com/archives/2685&t=Giants Roster Moves: 3 Signed, 3 Waived', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
	    <span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span>
	</a>
    <a class="mh-col mh-1-4 mh-twitter" href="#" onclick="window.open('http://twitter.com/share?text=Giants Roster Moves: 3 Signed, 3 Waived -&url=https://insidefootball.com/archives/2685', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
	    <span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span>
	</a>
    <a class="mh-col mh-1-4 mh-pinterest" href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://insidefootball.com/archives/2685&media=https://insidefootball.com/wp-content/uploads/2017/01/transaction.jpg&description=Giants Roster Moves: 3 Signed, 3 Waived', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
	    <span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span>
	</a>
    <a class="mh-col mh-1-4 mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://insidefootball.com/archives/2685', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
	    <span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span>
	</a>
</div><nav class="post-nav-wrap" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<ul class="post-nav clearfix">
<li class="post-nav-prev">
<a href="https://insidefootball.com/archives/2678" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li>
</ul>
</nav>
<div class="comments-wrap">
<h4 class="comment-section-title"><span class="comment-count">Be the first to comment</span> <span class="comment-count-more">on "Giants Roster Moves: 3 Signed, 3 Waived"</span></h4>
</div>
<p class="must-log-in">You must <a href="https://insidefootball.com/login?redirect_to=https://insidefootball.com/archives/2685#respond">log in</a> to post a comment.</p>	</div>
	<aside class="mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	<div id="image-4" class="sb-widget clearfix widget_image"><h4 class="widget-title"><span>Order Inside Football</span></h4><div class="jetpack-image-container"><figure style="width: 500px" class="wp-caption aligncenter">
					<a  href="http://shop.insidefootball.com/"><img src="https://i0.wp.com/insidefootball.com/wp-content/uploads/2017/04/subscribe.jpg?resize=500%2C100&#038;ssl=1" data-recalc-dims="1" /></a>
					<figcaption class="wp-caption-text">3-issue "Spring Football" package ... 26 issues (full year) ... 56 issues (two years) ...
<b>Save $10 on any 1- or 2-year package with discount code GOGIANTS. Valid  through June 30, 2017</b></figcaption>
				</figure></div>
</div><div id="wpcom_social_media_icons_widget-2" class="sb-widget clearfix widget_wpcom_social_media_icons_widget"><h4 class="widget-title"><span>Follow us on Social Media</span></h4><ul><li><a href="https://www.facebook.com/InsideFootball/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View InsideFootball&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/Patricia_Traina/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View Patricia_Traina&#8217;s profile on Twitter</span></a></li><li><a href="https://www.instagram.com/ptwrites/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View ptwrites&#8217;s profile on Instagram</span></a></li><li><a href="https://plus.google.com/u/0/+Patricia Traina/" class="genericon genericon-googleplus" target="_blank"><span class="screen-reader-text">View Patricia Traina&#8217;s profile on Google+</span></a></li></ul></div><div id="blog_subscription-2" class="sb-widget clearfix jetpack_subscription_widget"><h4 class="widget-title"><span>Subscribe to Blog via Email</span></h4>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive FREE notifications of new posts by email.</p>
</div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="https://insidefootball.com/archives/2685" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</div><div id="text-20" class="sb-widget clearfix widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Ad-01 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7201922328396792"
     data-ad-slot="1716271863"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div>		<div id="recent-posts-2" class="sb-widget clearfix widget_recent_entries">		<h4 class="widget-title"><span>Recent Posts</span></h4>		<ul>
					<li>
				<a href="https://insidefootball.com/archives/2685">Giants Roster Moves: 3 Signed, 3 Waived</a>
							<span class="post-date">May 13, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2678">Giants Rookie Minicamp Observations</a>
							<span class="post-date">May 13, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2670">Department of Defense: Middle Linebacker, Free Safety Jobs Open</a>
							<span class="post-date">May 12, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2665">Webb, Engram Form Early Bond on Giants Offense</a>
							<span class="post-date">May 12, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2657">Wayne Gallman is Hungry for Carries, Giants Cafeteria Food</a>
							<span class="post-date">May 12, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2654">How Soccer and Wrestling Helped Dalvin Tomlinson’s Football Career</a>
							<span class="post-date">May 12, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2637">New York Giants Rookie Minicamp Live Updates</a>
							<span class="post-date">May 12, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2627">Storylines to Watch at New York Giants Rookie Minicamp</a>
							<span class="post-date">May 11, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2630">Giants Announce Three Rookie Draft Pick Signings</a>
							<span class="post-date">May 11, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2624">Inside Football Subscriber Exclusive: Our Complete Interview Transcript with Jim Zorn</a>
							<span class="post-date">May 11, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2619">Giants Agree to Terms with DT Dalvin Tomlinson</a>
							<span class="post-date">May 10, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2612">What QB Davis Webb Has Been Learning from Former NFL QB Jim Zorn</a>
							<span class="post-date">May 10, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2607">Pat’s Perspectives: Injury Updates, Herzlich, and Davis Webb</a>
							<span class="post-date">May 10, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2597">Brandon Marshall Reveals 2-year Plan</a>
							<span class="post-date">May 6, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2590">Manning to Webb: Don&#8217;t Call Me Sir</a>
							<span class="post-date">May 5, 2017</span>
						</li>
					<li>
				<a href="https://insidefootball.com/archives/2584">New York Giants Reader Mailbag: Weekend Edition</a>
							<span class="post-date">May 5, 2017</span>
						</li>
				</ul>
		</div>		<div id="text-7" class="sb-widget clearfix widget_text">			<div class="textwidget"><a href="https://rspnutrition.com/?athletes=1599">RSP Nutrition</a>
<hr>
<a href="https://PatandEdShow.podbean.com" target="_blank">
<img style="width:297px;height:170px;border:none;" src="https://i0.wp.com/d8g345wuhgd7e.cloudfront.net/site/images/top10Badges/2016/sports_and_recreation.png?ssl=1" data-recalc-dims="1">
</a>
</div>
		</div><div id="text-8" class="sb-widget clearfix widget_text">			<div class="textwidget"><a href="http://www.ticketmonster.com/?aid=19235" target="_new">
<img src="https://i1.wp.com/dfzcfb18p6v47.cloudfront.net/images/widgets/football-300x250.jpg?resize=300%2C250&#038;ssl=1" alt="Ticket Monster - Cheap Tickets" data-recalc-dims="1">
</a></div>
		</div><div id="text-21" class="sb-widget clearfix widget_text">			<div class="textwidget"><a title="DMCA.com Protection Status" class="dmca-badge" href="http://www.dmca.com/Protection/Status.aspx?ID=7d72e5d2-aa0e-496f-bcb9-12ff2ba11556"> <img alt="DMCA.com Protection Status" src="https://i2.wp.com/images.dmca.com/Badges/dmca_protected_sml_120ae.png?ssl=1" data-recalc-dims="1"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script></div>
		</div></aside></div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
		<div class="wrapper-inner clearfix">
					<div class="mh-section mh-group footer-widgets">
									<div class="mh-col mh-1-3 footer-1">
						<div id="text-9" class="footer-widget widget_text">			<div class="textwidget">Inside Football is a fully accredited, independent media organization that is neither sponsored by nor affiliated with the New York Football Giants or National Football League. Your use of this website constitutes your have read and agree to the terms and conditions outlined under <a href="https://insidefootball.com/insidefootball-com-website-use-terms-and-conditions/">TERMS AND CONDITIONS</a>.</div>
		</div>					</div>
													<div class="mh-col mh-1-3 footer-2">
						<div id="text-14" class="footer-widget widget_text">			<div class="textwidget"><a href="https://insidefootball.com/meet-our-team/">Meet Our Team</a><P>
<a href="https://insidefootball.com/frequently-asked-questions/">Frequently Asked Questions</a><P>
<a href="http://shop.insidefootball.com/">Subscription Information</a><P>
<a href="https://insidefootball.com/insidefootball-com-website-use-terms-and-conditions/">Web Site Use Terms and Conditions</a><p>
<a href="https://insidefootball.com/inside-football-llc-web-site-privacy-policy/">Privacy Policy</a><P>
</div>
		</div>					</div>
													<div class="mh-col mh-1-3 footer-3">
						<div id="text-18" class="footer-widget widget_text">			<div class="textwidget">            <a class="twitter-timeline"  href="https://twitter.com/Patricia_Traina" data-widget-id="686314172284551171">Tweets by @Patricia_Traina</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          </div>
		</div>					</div>
							</div>
			</div>
	<div class="footer-bottom">
		<div class="wrapper-inner clearfix">
						<div class="copyright-wrap">
				<p class="copyright">
					©2007-2017 Inside Football LLC. Content may not be reproduced without express written consent from the Publisher. NFL and team logos are registered trademarks, and are used under the terms of the annual NFL media credential notice.				</p>
			</div>
		</div>
	</div>
</footer>
		<script type="text/javascript">
			(function($){
				$(document).ready(function() {
					$( '.cntctfrm_contact_form .cntctfrm_error, .cntctfrm_contact_form input[name^=cptch]' ).on( 'input paste change', function() {
						$( this ).removeClass( 'cntctfrm_error' );
						$( this ).next( '.cntctfrm_help_box' ).removeClass( 'cntctfrm_help_box_error' );
						$( this ).parent( '.cptch_block, .cptchpr_block' ).next( '.cntctfrm_help_box' ).removeClass( 'cntctfrm_help_box_error' );
						if ( $( this ).is( 'input[type=checkbox].cntctfrm_privacy_check' ) && $( this ).is( ':checked' ) ) {
							$( this ).prev( '#error_privacy_check' ).css( 'display', 'none' );
						}
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box' ).bind( 'show_tooltip', function() {
						$help_box = $( this ).children();
						$( this ).removeClass( 'cntctfrm_hide_tooltip' );
						$( this ).addClass( 'cntctfrm_show_tooltip' );
						if ( $help_box.offset().left + $help_box.innerWidth() > $( window ).width() ) {
							$help_box.addClass( 'cntctfrm_hidden_help_text_down' );
						}
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box' ).bind( 'hide_tooltip', function() {
						$help_box = $( this ).children();
						$( this ).removeClass( 'cntctfrm_show_tooltip' );
						$( this ).addClass( 'cntctfrm_hide_tooltip' );
						$help_box.removeClass( 'cntctfrm_hidden_help_text_down' );
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box' ).mouseenter( function() {
						$( this ).trigger( 'show_tooltip' );
					}).mouseleave( function() {
						$( this ).trigger( 'hide_tooltip' );
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box.cntctfrm_show_tooltip' ).on( 'click', function() {
						$( this ).trigger( 'hide_tooltip' );
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box.cntctfrm_hide_tooltip' ).on( 'click', function() {
						$( this ).trigger( 'show_tooltip' );
					});
				});
			})(jQuery);
		</script>
	

 <div id="formillachat" style="z-index:100 "></div><div id="formillawindowholder"><span style="display:none"></span></div><script type="text/javascript">      (function () {       var head = document.getElementsByTagName("head").item(0);       var script = document.createElement('script');       var src = (document.location.protocol == "https:" ? 'https://www.formilla.com/scripts/feedback.js' : 'http://www.formilla.com/scripts/feedback.js');      script.setAttribute("type", "text/javascript"); script.setAttribute("src", src); script.setAttribute("async", true);       var complete = false;       script.onload = script.onreadystatechange = function () {         if (!complete && (!this.readyState || this.readyState == 'loaded' || this.readyState == 'complete')) {           complete = true;           Formilla.guid = 'csb9eb3e-bf57-4bf9-b186-2929b1c3432c';          Formilla.loadFormillaChatButton();             }      };       head.appendChild(script);   })();  </script> 	<script type="text/javascript" language="javascript">
		jQuery(document).ready(function($){
					});
	</script>
    <style type="text/css">
				
	</style>
	<script type="text/javascript" language="javascript">
		//		
	jQuery(document).ready(function($) {
		
			});	
	</script>
	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/insidefootball.com\/archives\/2685":2685};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/archives/2685" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://insidefootball.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
			<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/plusone.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
								<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<script type="text/javascript" src="https://platform.tumblr.com/v1/share.js"></script>		<script>
		// Don't use Pocket's default JS as it we need to force init new Pocket share buttons loaded via JS.
		function jetpack_sharing_pocket_init() {
			jQuery.getScript( 'https://widgets.getpocket.com/v1/j/btn.js?v=1' );
		}
		jQuery( document ).ready( jetpack_sharing_pocket_init );
		jQuery( document.body ).on( 'post-load', jetpack_sharing_pocket_init );
		</script>
		<link rel='stylesheet' id='genericons-css'  href='https://insidefootball.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201719'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpps_options_object = {"scroll_up":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jquery-post-splitter/js/paged-post-jquery.js?ver=4.7.4'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Mayaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/comment-reply.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/_inc/postmessage.js?ver=4.9'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=4.9'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=4.9'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
		<iframe src='https://widgets.wp.com/likes/master.html?ver=20160429#ver=20160429' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		
		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201719.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'122731363',post:'2685',tz:'-4',srv:'insidefootball.com'} ]);
	_stq.push([ 'clickTrackerInit', '122731363', '2685' ]);
</script>
</body>
</html>