<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://insidefootball.com/xmlrpc.php" />
<title>The Friday 5: Coaching Staff, Free Agency, Injuries and More &raquo; Inside Football</title>
          <script>
            (function(d){
              var js, id = 'powr-js', ref = d.getElementsByTagName('script')[0];
              if (d.getElementById(id)) {return;}
              js = d.createElement('script'); js.id = id; js.async = true;
              js.src = '//www.powr.io/powr.js';
              js.setAttribute('powr-token','2PdKIgicsP1489427081');
              js.setAttribute('external-type','wordpress');
              ref.parentNode.insertBefore(js, ref);
            }(document));
          </script>
          <!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="ybFai74nFlZtfAEyMq-DlMquwzZxeG4QFQe3AZ7ffi4" />

<!-- This site is optimized with the Yoast SEO plugin v6.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Friday 5: Coaching Staff, Free Agency, Injuries and More &raquo; Inside Football" />
<meta property="og:description" content="It&#8217;s time for another installment of the Friday 5 with..." />
<meta property="og:url" content="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/" />
<meta property="og:site_name" content="Inside Football" />
<meta property="article:publisher" content="https://www.facebook.com/InsideFootball" />
<meta property="article:section" content="friday 5" />
<meta property="article:published_time" content="2018-02-16T08:00:16-05:00" />
<meta property="article:modified_time" content="2018-02-15T11:32:07-05:00" />
<meta property="og:updated_time" content="2018-02-15T11:32:07-05:00" />
<meta property="og:image" content="https://insidefootball.com/wp-content/uploads/2018/01/Depositphotos_137231330_s-2015.jpg" />
<meta property="og:image:secure_url" content="https://insidefootball.com/wp-content/uploads/2018/01/Depositphotos_137231330_s-2015.jpg" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="333" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="It&#8217;s time for another installment of the Friday 5 with..." />
<meta name="twitter:title" content="The Friday 5: Coaching Staff, Free Agency, Injuries and More &raquo; Inside Football" />
<meta name="twitter:site" content="@Patricia_Traina" />
<meta name="twitter:image" content="https://insidefootball.com/wp-content/uploads/2018/01/Depositphotos_137231330_s-2015.jpg" />
<meta name="twitter:creator" content="@Patricia_Traina" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/insidefootball.com\/","name":"Inside Football","alternateName":"Inside Football: New York Giants News, Notes and Analysis","potentialAction":{"@type":"SearchAction","target":"https:\/\/insidefootball.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/insidefootball.com\/friday-5-coaching-staff-free-agency-injuries\/","sameAs":["https:\/\/www.facebook.com\/InsideFootball","http:\/\/ptwrites","https:\/\/twitter.com\/Patricia_Traina"],"@id":"#organization","name":"Inside Football: New York Giants News, Notes and Analysis","logo":"https:\/\/insidefootball.com\/wp-content\/uploads\/2017\/01\/fulllogo.gif"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Inside Football &raquo; Feed" href="https://insidefootball.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Inside Football &raquo; Comments Feed" href="https://insidefootball.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Inside Football &raquo; iCal Feed" href="https://insidefootball.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Inside Football &raquo; The Friday 5: Coaching Staff, Free Agency, Injuries and More Comments Feed" href="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/insidefootball.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mpsp-custom-style-css'  href='https://insidefootball.com/wp-content/plugins/testimonial-add/css/custom_style.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='mpsp-style-css'  href='https://insidefootball.com/wp-content/plugins/testimonial-add/owl-carousel/owl.carousel.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='mpsp_theme-css'  href='https://insidefootball.com/wp-content/plugins/testimonial-add/owl-carousel/owl.theme.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='mpsp_transitions-css'  href='https://insidefootball.com/wp-content/plugins/testimonial-add/owl-carousel/owl.transitions.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='mp-theme-css'  href='https://insidefootball.com/wp-content/plugins/memberpress/css/ui/theme.css?ver=1.3.24' type='text/css' media='all' />
<link rel='stylesheet' id='cntctfrm_form_style-css'  href='https://insidefootball.com/wp-content/plugins/contact-form-pro/css/form_style.css?ver=4.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='edd-styles-css'  href='https://insidefootball.com/wp-content/plugins/easy-digital-downloads/templates/edd.min.css?ver=2.8.18' type='text/css' media='all' />
<link rel='stylesheet' id='collapseomatic-css-css'  href='https://insidefootball.com/wp-content/plugins/jquery-collapse-o-matic/dark_style.css?ver=1.6' type='text/css' media='all' />
<link rel='stylesheet' id='ctdb-style-css'  href='https://insidefootball.com/wp-content/plugins/wp-discussion-board/assets/css/style.css?ver=2.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://insidefootball.com/wp-includes/css/dashicons.min.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='mh-style-css'  href='https://insidefootball.com/wp-content/themes/mh_newsdesk/style.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://insidefootball.com/wp-content/themes/mh_newsdesk/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700%7cOswald:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://insidefootball.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='rpt-css'  href='https://insidefootball.com/wp-content/plugins/responsive-pricing-table-pro/inc/css/rpt_style.min.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://insidefootball.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://insidefootball.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.8' type='text/css' media='all' />
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/testimonial-add/owl-carousel/owl.carousel.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/top-bar/js/jquery.cookie.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tpbr_settings = {"fixed":"fixed","message":"Use code RENEW to save $10 off any subscription package.","status":"active","yn_button":"button","color":"#B8312F","button_text":"Click for plans and pricing info.","button_url":"https:\/\/insidefootball.com\/subscription-plans\/","is_admin_bar":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/top-bar/js/tpbr_front.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/responsive-pricing-table-pro/inc/js/rptp.min.js?ver=4.9.4'></script>
<link rel='https://api.w.org/' href='https://insidefootball.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://insidefootball.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://insidefootball.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.4" />
<link rel='shortlink' href='https://wp.me/p8iY27-1FB' />
<link rel="alternate" type="application/json+oembed" href="https://insidefootball.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidefootball.com%2Ffriday-5-coaching-staff-free-agency-injuries%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://insidefootball.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidefootball.com%2Ffriday-5-coaching-staff-free-agency-injuries%2F&#038;format=xml" />
<meta name="generator" content="Easy Digital Downloads v2.8.18" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://insidefootball.com"><link rel="https://theeventscalendar.com/" href="https://insidefootball.com/wp-json/tribe/events/v1/" /><script type="text/javascript">
           	 	var ajaxurl = "https://insidefootball.com/wp-admin/admin-ajax.php";
         	</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>	<style type="text/css">
    	    		.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover .pagelink { color: #010035; }
			.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination .pagelink { background: #010035; }
			blockquote, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover, textarea:hover { border-color: #010035; }
    	    				.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink, .comment-section-title { background: #e2e2e2; }
			.commentlist .depth-1, .commentlist .bypostauthor .avatar { border-color: #e2e2e2; }
    	    	    				.header-top, .header-nav ul li:hover > ul, .footer-ad-wrap, .footer-1, .footer-2, .footer-3, .footer-bottom { background: #0a0a0a; }
			.social-nav a { color: #0a0a0a; }
    	    	    		</style>
    <!--[if lt IE 9]>
<script src="https://insidefootball.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://insidefootball.com/wp-content/uploads/2017/01/favicon-16x16.png" sizes="32x32" />
<link rel="icon" href="https://insidefootball.com/wp-content/uploads/2017/01/favicon-16x16.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://insidefootball.com/wp-content/uploads/2017/01/favicon-16x16.png" />
<meta name="msapplication-TileImage" content="https://insidefootball.com/wp-content/uploads/2017/01/favicon-16x16.png" />
</head>
<body class="post-template-default single single-post postid-6423 single-format-standard tribe-no-js ctdb-layout-classic ctdb-archive-layout-classic ctdb-mh-newsdesk ctdb-user-cannot-view ctdb-user-cannot-post mh-right-sb mh-loop-layout1" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div id="mh-wrapper">
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="header-wrap clearfix">
				<div class="mh-col mh-1-3 header-logo-full">
			<a href="https://insidefootball.com/" title="Inside Football" rel="home">
<div class="logo-wrap" role="banner">
<img src="https://insidefootball.com/wp-content/uploads/2017/01/cropped-fulllogo.gif" height="163" width="866" alt="Inside Football" />
</div>
</a>
		</div>
			</div>
	<div class="header-menu clearfix">
		<nav class="main-nav clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-672"><a href="https://insidefootball.com/">HOME</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a href="#">ABOUT US</a>
<ul class="sub-menu">
	<li id="menu-item-126" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-126"><a href="https://insidefootball.com/meet-our-team/">Meet Our Team</a></li>
	<li id="menu-item-3249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3249"><a href="https://insidefootball.com/advertise-with-us/">Advertise with Us</a></li>
</ul>
</li>
<li id="menu-item-52" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-52"><a href="#">TEAM INFO</a>
<ul class="sub-menu">
	<li id="menu-item-5855" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5855"><a href="https://insidefootball.com/2018-new-york-giants-schedule/">2018 Regular-Season Opponents</a>
	<ul class="sub-menu">
		<li id="menu-item-189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="https://insidefootball.com/new-york-giants-2017-schedule/">2017 Schedule</a></li>
		<li id="menu-item-3620" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3620"><a href="https://insidefootball.com/2017-new-york-giants-uniform-schedule/">2017 New York Giants Uniform Schedule</a></li>
	</ul>
</li>
	<li id="menu-item-50" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50"><a href="http://www.giants.com/team/statistics.html">Team Statistics</a></li>
	<li id="menu-item-51" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-51"><a href="http://www.nfl.com/standings?category=div">Standings (via NFL.com)</a></li>
	<li id="menu-item-181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181"><a href="https://insidefootball.com/team-contact-information/">Team Contact Information</a></li>
	<li id="menu-item-272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-272"><a href="https://insidefootball.com/rosters/">Rosters</a>
	<ul class="sub-menu">
		<li id="menu-item-298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298"><a href="https://insidefootball.com/unofficial-depth-charts/">Unofficial Depth Charts</a></li>
		<li id="menu-item-55" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55"><a href="#">Transactions</a>
		<ul class="sub-menu">
			<li id="menu-item-6052" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6052"><a href="https://insidefootball.com/2017-transactions-2/">2018 Transactions</a></li>
			<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://insidefootball.com/2017-transactions/">2017 Transactions</a></li>
			<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://insidefootball.com/2016-transactions/">2016 Transactions</a></li>
			<li id="menu-item-157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-157"><a href="https://insidefootball.com/2015-transactions/">2015 Transactions</a></li>
			<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://insidefootball.com/2014-transactions/">2014 Transactions</a></li>
			<li id="menu-item-159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159"><a href="https://insidefootball.com/2013-transactions/">2013 Transactions</a></li>
		</ul>
</li>
	</ul>
</li>
	<li id="menu-item-273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-273"><a href="https://insidefootball.com/coaching-staff/">Coaching Staff</a></li>
</ul>
</li>
<li id="menu-item-105" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-105"><a href="#">CUSTOMER SERVICE</a>
<ul class="sub-menu">
	<li id="menu-item-108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108"><a href="https://insidefootball.com/technical-support-disclaimer/">Technical Support Disclaimer</a></li>
	<li id="menu-item-510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-510"><a href="https://insidefootball.com/how-to-access-your-account/">Logging In/Resetting Your Password</a></li>
	<li id="menu-item-1637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1637"><a href="https://insidefootball.com/how-do-i-know-if-im-already-logged-in/">How Do I Know If I’m Already Logged In?</a></li>
	<li id="menu-item-509" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-509"><a href="https://insidefootball.com/understanding-your-accountsubscriptions/">Your Account Dashboard</a></li>
	<li id="menu-item-746" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-746"><a target="_blank" href="https://insidefootball.com/how-to-access-subscription-material-and-premium-content/">Access Subscription Material/Premium Content</a></li>
</ul>
</li>
<li id="menu-item-654" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-654"><a href="https://insidefootball.com/subscription-plans/">SUBSCRIPTION INFO</a>
<ul class="sub-menu">
	<li id="menu-item-1217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1217"><a href="https://insidefootball.com/inside-football-full-sample-issue/">Full Sample Issue</a></li>
	<li id="menu-item-271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271"><a href="https://insidefootball.com/subscriber-testimonials/">Reader Testimonials</a></li>
</ul>
</li>
<li id="menu-item-307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-307"><a href="#">FOOTBALL RESOURCES</a>
<ul class="sub-menu">
	<li id="menu-item-6060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6060"><a href="https://insidefootball.com/2018-free-agency-scorecard/">2018 Free Agency Scorecard</a></li>
	<li id="menu-item-788" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-788"><a href="https://insidefootball.com/blog-posts/">Blog Post Archive</a></li>
	<li id="menu-item-2897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2897"><a href="https://insidefootball.com/events/">Giants, NFL Event Calendar</a></li>
	<li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://insidefootball.com/related-links/">Related Links &#038; Twitter Resources</a></li>
	<li id="menu-item-57" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57"><a href="http://overthecap.com/salary-cap/new-york-giants/">Contract/Salary Info (via Over the Cap)</a></li>
	<li id="menu-item-308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-308"><a href="https://insidefootball.com/salary-cap-primer-faq/">Understanding the Salary Cap</a></li>
	<li id="menu-item-1034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1034"><a href="https://insidefootball.com/nfl-proposed-minimum-salary-table/">NFL Proposed Minimum Salaries</a></li>
	<li id="menu-item-937" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-937"><a href="http://overthecap.com/the-basics-and-methodology-of-projecting-the-nfls-compensatory-draft-picks/">Comp Draft Pick Info (per OTC)</a></li>
	<li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://insidefootball.com/ask-the-official/">Ask the Official</a></li>
</ul>
</li>
<li id="menu-item-449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-449"><a href="https://insidefootball.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130"><a href="https://insidefootball.com/letters-to-the-editor/">Reader Interactive</a></li>
<li id="menu-item-676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-676"><a href="https://insidefootball.com/account/">MY ACCOUNT (Login)</a>
<ul class="sub-menu">
	<li id="menu-item-789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-789"><a href="https://insidefootball.com/category/premium/">Subscriber Content</a></li>
</ul>
</li>
</ul></div>		</nav>
		<div class="header-sub clearfix">
							<div id="ticker" class="news-ticker mh-col mh-2-3 clearfix">
			<span class="ticker-title">
			WHAT&#039;S NEW		</span>
		<ul class="ticker-content">			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/" title="The Friday 5: Coaching Staff, Free Agency, Injuries and More">
					<span class="ticker-item-date">February 16, 2018</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">The Friday 5: Coaching Staff, Free Agency, Injuries and More</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/giants-announce-coaching-staff/" title="Giants Announce Coaching Staff">
					<span class="ticker-item-date">February 15, 2018</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Giants Announce Coaching Staff</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/reader-mailbag-defensive-changes-coaching-questions/" title="Reader Mailbag: Defensive Changes, Coaching Questions and More">
					<span class="ticker-item-date">February 15, 2018</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Reader Mailbag: Defensive Changes, Coaching Questions and More</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/geoffmags-mike-shula-giants-get-another-quarterback-whisperer/" title="GeoffMags: In Mike Shula, Giants Get Another Quarterback Whisperer">
					<span class="ticker-item-date">February 13, 2018</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">GeoffMags: In Mike Shula, Giants Get Another Quarterback Whisperer</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://insidefootball.com/report-giants-hire-mike-shula-new-offensive-coordinator-quarterbacks-coach/" title="Report: Giants Hire Mike Shula as Their New Offensive Coordinator/Quarterbacks Coach">
					<span class="ticker-item-date">February 13, 2018</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Report: Giants Hire Mike Shula as Their New Offensive Coordinator/Quarterbacks Coach</span>
				</a>
			</li>	</ul>
</div>						<aside class="mh-col mh-1-3 header-search">
				<form role="search" method="get" class="search-form" action="https://insidefootball.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</aside>
		</div>
	</div>
</header><div class="mh-section mh-group">
	<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><article id="post-6423" class="post-6423 post type-post status-publish format-standard has-post-thumbnail hentry category-friday-5">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			The Friday 5: Coaching Staff, Free Agency, Injuries and More		</h1>	</header><p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="https://insidefootball.com/author/patriciatraina/">Patricia Traina</a></span>
<span class="entry-meta-date updated">February 16, 2018</span>
</p>
	<div class="entry-content clearfix">
		<p>It&#8217;s time for another installment of the Friday 5 with Ed Valentine of Big Blue View. Below are Ed&#8217;s answers to this week&#8217;s questions. You can see my answers to these same questions on <a href="http://www.bigblueview.com">Big Blue View</a>.</p>
<p><strong>With Pat Shurmur’s assistant coaching staff pretty much complete, what is your overall takeaway on the staff’s makeup?</strong></p>
<p><strong>Ed says:</strong> Let&#8217;s briefly break that down into its three essential parts.</p>
<p>Offense &#8212; There are some who are freaked out by the Mike Shula hire. I&#8217;m not. He won&#8217;t be designing the scheme or calling the plays. He&#8217;s a veteran guy with a reputation for bring creative. As long as he adds value to the offense, that&#8217;s fine. I think it&#8217;s Shula&#8217;s work with QBs that will be the big test, especially if the Giants draft one second overall.</p>
<p>The hire on the offensive side of the ball that concerns me is offensive line coach Hal Hunter. It&#8217;s a critical spot and Hunter is a veteran coach, but the NFL lines (Chargers, Colts, Browns) he has coached haven&#8217;t been great. And, he didn&#8217;t have a job last year.</p>
<p>Defense &#8212; The Giants have to be ecstatic about the hiring of James Bettcher. He brings an aggressive, multiple style and it should be a lot of fun to see the defense unfold.</p>
<p>Special teams &#8212; Hey, Tom Quinn is gone. Life is good.</p>
<p><strong>Give me one player you would be absolutely stunned to see cut for salary cap purposes.</strong></p>
<p><strong>Ed says:</strong> That would have to be Janoris Jenkins. I listed Jackrabbit<a href="https://www.bigblueview.com/2018/2/14/17009650/nfl-salary-cap-cuts-are-coming-which-ny-giants-will-stay-go-brandon-marshall-eli-apple"> among possible cuts</a> when I wrote about this at Big Blue View earlier in the week. I mean, I kind of had to. The Giants could save $11 million against the salary cap by making him a  post-June 1 cut.</p>
<p>That said, there is too much uncertainty at the position for them to part with Jenkins. Ross Cockrell is a free agent, chances are good the Giants move on from Dominique Rodgers-Cromartie, and Eli Apple&#8217;s future is up in the air.</p>
<p><strong>Whip out your crystal ball and tell me which position do you think the Giants will address in free agency?</strong></p>
<p><strong>Ed says: </strong>Well, it&#8217;s a no-brainer that this has to be the offensive line. I fully expect them to make a big run at Carolina Panthers guard Andrew Norwell, the best lineman on the market and a guy Dave Gettleman signed in Carolina.</p>
<p>I would like to see D.J. Fluker brought back on a one- or two-year deal. If they can find an affordable tackle in free agency, I&#8217;m all for that, too.</p>
<p>One thing: I have seen the idea of re-signing Justin Pugh to play tackle floated. I guess it&#8217;s possible, but I don&#8217;t like it. You would be paying the guy a lot of money to line up at a position that isn&#8217;t his best.</p>
<p><strong>We haven’t discussed season-ending injuries, so let’s do it now. Which player or players are you most concerned about potentially being ready for the start of training camp?</strong></p>
<p><strong>Ed says:</strong> I&#8217;d say that has to be Odell Beckham. Not because I don&#8217;t think he will be ready, but simply because of how much of a difference-maker he is. We have both argued that the Giants should wait to pay him, and we&#8217;re probably in the minority. But, there is no argument that he is their best offensive player. A healthy Beckham is important, and I also think it&#8217;s critical that he get as much practice time as possible in the offense being installed by Pat Shurmur.</p>
<p><strong>And on that same vein, give me the one position unit that you think could be affected in either free agency or the draft because of that injury concern.</strong></p>
<p><strong>Ed says:</strong> Linebacker. I have written at Big Blue View about the importance of <a href="https://www.bigblueview.com/2018/2/9/16990274/time-for-ny-giants-to-get-serious-about-finding-good-linebackers-bj-goodson-nfl-draft-free-agency">finally investing real resources at the linebacker spot</a>. Injuries or not, I think this is critical. Bettcher&#8217;s defenses have been heavily reliant on 3-4 looks, and the Giants don&#8217;t have enough good ones.</p>
<p>Jonathan Casillas is a free agent and his neck injury could be career-ending. Mark Herzlich wants to come back, but hasn&#8217;t been a reliable linebacker for a long time. Devon Kennard is a free agent. B.J. Goodson couldn&#8217;t stay on the field last season.</p>
<p>Unfortunately, unless Nigel Bradham wants to leave the Eagles, there doesn&#8217;t appear to be much more than stop-gap help available in free agency. I will be sorely disappointed if the Giants don&#8217;t address the linebacker position in the first two days of the upcoming draft.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/" data-text="The Friday 5: Coaching Staff, Free Agency, Injuries and More" data-via="InsideFootball" >Tweet</a></li><li class="share-facebook"><div class="fb-share-button" data-href="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/" data-layout="button_count"></div></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/"></div></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Finsidefootball.com%2Ffriday-5-coaching-staff-free-agency-injuries%2F&#038;media=https%3A%2F%2Finsidefootball.com%2Fwp-content%2Fuploads%2F2018%2F01%2FDepositphotos_137231330_s-2015.jpg&#038;description=The%20Friday%205%3A%20Coaching%20Staff%2C%20Free%20Agency%2C%20Injuries%20and%20More" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-tumblr"><a target="_blank" href="https://www.tumblr.com/share/link/?url=https%3A%2F%2Finsidefootball.com%2Ffriday-5-coaching-staff-free-agency-injuries%2F&name=The%20Friday%205%3A%20Coaching%20Staff%2C%20Free%20Agency%2C%20Injuries%20and%20More" title="Share on Tumblr" style="display:inline-block; text-indent:-9999px; overflow:hidden; width:62px; height:20px; background:url('https://platform.tumblr.com/v1/share_2.png') top left no-repeat transparent;">Share on Tumblr</a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button" href="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-pocket"><div class="pocket_button"><a href="https://getpocket.com/save" class="pocket-btn" data-lang="en" data-save-url="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/" data-pocket-count="horizontal" >Pocket</a></div></li><li class="share-end"></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button" href="https://api.whatsapp.com/send?text=The%20Friday%205%3A%20Coaching%20Staff%2C%20Free%20Agency%2C%20Injuries%20and%20More https%3A%2F%2Finsidefootball.com%2Ffriday-5-coaching-staff-free-agency-injuries%2F" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-122731363-6423-5a86d5f9093d8' data-src='https://widgets.wp.com/likes/#blog_id=122731363&amp;post_id=6423&amp;origin=insidefootball.com&amp;obj_id=122731363-6423-5a86d5f9093d8' data-name='like-post-frame-122731363-6423-5a86d5f9093d8'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div>	</div>
	</article><div class="mh-share-buttons mh-group">
    <a class="mh-col mh-1-4 mh-facebook" href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/&t=The Friday 5: Coaching Staff, Free Agency, Injuries and More', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
	    <span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span>
	</a>
    <a class="mh-col mh-1-4 mh-twitter" href="#" onclick="window.open('http://twitter.com/share?text=The Friday 5: Coaching Staff, Free Agency, Injuries and More -&url=https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
	    <span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span>
	</a>
    <a class="mh-col mh-1-4 mh-pinterest" href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/&media=https://insidefootball.com/wp-content/uploads/2018/01/Depositphotos_137231330_s-2015.jpg&description=The Friday 5: Coaching Staff, Free Agency, Injuries and More', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
	    <span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span>
	</a>
    <a class="mh-col mh-1-4 mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
	    <span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span>
	</a>
</div><nav class="post-nav-wrap" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<ul class="post-nav clearfix">
<li class="post-nav-prev">
<a href="https://insidefootball.com/giants-announce-coaching-staff/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li>
</ul>
</nav>
<div class="comments-wrap">
<h4 class="comment-section-title"><span class="comment-count">Be the first to comment</span> <span class="comment-count-more">on "The Friday 5: Coaching Staff, Free Agency, Injuries and More"</span></h4>
</div>
<p class="must-log-in">You must <a href="https://insidefootball.com/login/?redirect_to=https%3A%2F%2Finsidefootball.com%2Ffriday-5-coaching-staff-free-agency-injuries%2F%23respond">log in</a> to post a comment.</p>	</div>
	<aside class="mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	<div id="mh_newsdesk_custom_posts-4" class="sb-widget clearfix mh_newsdesk_custom_posts"><h4 class="widget-title"><span><a href="https://insidefootball.com/category/premium/" class="widget-title-link">Inside Football Subscriber Content (Login Required)</a></span></h4>			<div class="mh-cp-widget clearfix">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://insidefootball.com/inside-football-issue-2017-season-review/" title="Inside Football Issue: 2017 Season in Review"><img width="120" height="67" src="https://insidefootball.com/wp-content/uploads/2017/01/subscription-play-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="" srcset="https://insidefootball.com/wp-content/uploads/2017/01/subscription-play-120x67.jpg 120w, https://insidefootball.com/wp-content/uploads/2017/01/subscription-play-180x101.jpg 180w, https://insidefootball.com/wp-content/uploads/2017/01/subscription-play-260x146.jpg 260w, https://insidefootball.com/wp-content/uploads/2017/01/subscription-play-373x210.jpg 373w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="https://insidefootball.com/inside-football-issue-2017-season-review/" title="Inside Football Issue: 2017 Season in Review" rel="bookmark">
									Inside Football Issue: 2017 Season in Review								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://insidefootball.com/rs16-17-giants-18-washington-10/" title="Inside Football Issue RS16-17: Giants 18 &#8211; Washington 10 (Postgame Issue)"><img width="120" height="67" src="https://insidefootball.com/wp-content/uploads/2017/04/lockerroom-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="" srcset="https://insidefootball.com/wp-content/uploads/2017/04/lockerroom-120x67.jpg 120w, https://insidefootball.com/wp-content/uploads/2017/04/lockerroom-180x101.jpg 180w, https://insidefootball.com/wp-content/uploads/2017/04/lockerroom-260x146.jpg 260w, https://insidefootball.com/wp-content/uploads/2017/04/lockerroom-373x210.jpg 373w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="https://insidefootball.com/rs16-17-giants-18-washington-10/" title="Inside Football Issue RS16-17: Giants 18 &#8211; Washington 10 (Postgame Issue)" rel="bookmark">
									Inside Football Issue RS16-17: Giants 18 &#8211; Washington 10 (Postgame Issue)								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://insidefootball.com/inside-football-issue-rs15-17-cardinals-23-giants-0-postgame-issue/" title="Inside Football Issue RS15-17: Cardinals 23 – Giants 0 (Postgame Issue)"><img width="120" height="67" src="https://insidefootball.com/wp-content/uploads/2017/12/Depositphotos_88299854_s-2015-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="" srcset="https://insidefootball.com/wp-content/uploads/2017/12/Depositphotos_88299854_s-2015-120x67.jpg 120w, https://insidefootball.com/wp-content/uploads/2017/12/Depositphotos_88299854_s-2015-180x101.jpg 180w, https://insidefootball.com/wp-content/uploads/2017/12/Depositphotos_88299854_s-2015-260x146.jpg 260w, https://insidefootball.com/wp-content/uploads/2017/12/Depositphotos_88299854_s-2015-373x210.jpg 373w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="https://insidefootball.com/inside-football-issue-rs15-17-cardinals-23-giants-0-postgame-issue/" title="Inside Football Issue RS15-17: Cardinals 23 – Giants 0 (Postgame Issue)" rel="bookmark">
									Inside Football Issue RS15-17: Cardinals 23 – Giants 0 (Postgame Issue)								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://insidefootball.com/inside-football-issue-rs14-17-eagles-34-giants-29-postgame-issue/" title="Inside Football Issue RS14-17: Eagles 34 – Giants 29 (Postgame Issue)"><img width="120" height="67" src="https://insidefootball.com/wp-content/uploads/2017/01/footballbackground-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="" srcset="https://insidefootball.com/wp-content/uploads/2017/01/footballbackground-120x67.jpg 120w, https://insidefootball.com/wp-content/uploads/2017/01/footballbackground-180x101.jpg 180w, https://insidefootball.com/wp-content/uploads/2017/01/footballbackground-260x146.jpg 260w, https://insidefootball.com/wp-content/uploads/2017/01/footballbackground-373x210.jpg 373w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="https://insidefootball.com/inside-football-issue-rs14-17-eagles-34-giants-29-postgame-issue/" title="Inside Football Issue RS14-17: Eagles 34 – Giants 29 (Postgame Issue)" rel="bookmark">
									Inside Football Issue RS14-17: Eagles 34 – Giants 29 (Postgame Issue)								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="https://insidefootball.com/inside-football-issue-rs13-17-dallas-30-giants-10-postgame-issue/" title="Inside Football Issue RS13-17: Dallas 30 – Giants 10 (Postgame Issue)"><img width="120" height="67" src="https://insidefootball.com/wp-content/uploads/2017/02/analysis2-120x67.jpg" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="New York Giants" srcset="https://insidefootball.com/wp-content/uploads/2017/02/analysis2-120x67.jpg 120w, https://insidefootball.com/wp-content/uploads/2017/02/analysis2-180x101.jpg 180w, https://insidefootball.com/wp-content/uploads/2017/02/analysis2-260x146.jpg 260w, https://insidefootball.com/wp-content/uploads/2017/02/analysis2-373x210.jpg 373w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="https://insidefootball.com/inside-football-issue-rs13-17-dallas-30-giants-10-postgame-issue/" title="Inside Football Issue RS13-17: Dallas 30 – Giants 10 (Postgame Issue)" rel="bookmark">
									Inside Football Issue RS13-17: Dallas 30 – Giants 10 (Postgame Issue)								</a>
							</h3>
						</article>
						<hr class="mh-separator">			</div></div><div id="custom_html-2" class="widget_text sb-widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Ad-01 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7201922328396792"
     data-ad-slot="1716271863"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>		<div id="recent-posts-2" class="sb-widget clearfix widget_recent_entries">		<h4 class="widget-title"><span>Recent Posts</span></h4>		<ul>
											<li>
					<a href="https://insidefootball.com/friday-5-coaching-staff-free-agency-injuries/">The Friday 5: Coaching Staff, Free Agency, Injuries and More</a>
											<span class="post-date">February 16, 2018</span>
									</li>
											<li>
					<a href="https://insidefootball.com/giants-announce-coaching-staff/">Giants Announce Coaching Staff</a>
											<span class="post-date">February 15, 2018</span>
									</li>
											<li>
					<a href="https://insidefootball.com/reader-mailbag-defensive-changes-coaching-questions/">Reader Mailbag: Defensive Changes, Coaching Questions and More</a>
											<span class="post-date">February 15, 2018</span>
									</li>
											<li>
					<a href="https://insidefootball.com/geoffmags-mike-shula-giants-get-another-quarterback-whisperer/">GeoffMags: In Mike Shula, Giants Get Another Quarterback Whisperer</a>
											<span class="post-date">February 13, 2018</span>
									</li>
											<li>
					<a href="https://insidefootball.com/report-giants-hire-mike-shula-new-offensive-coordinator-quarterbacks-coach/">Report: Giants Hire Mike Shula as Their New Offensive Coordinator/Quarterbacks Coach</a>
											<span class="post-date">February 13, 2018</span>
									</li>
											<li>
					<a href="https://insidefootball.com/whats-next-giants-search-offensive-coordinator/">What&#8217;s Next for the Giants Search for an Offensive Coordinator?</a>
											<span class="post-date">February 11, 2018</span>
									</li>
											<li>
					<a href="https://insidefootball.com/report-vikings-decline-kevin-stefanski-permission-interview-giants/">Report: Vikings Decline Kevin Stefanski Permission to Interview with Giants</a>
											<span class="post-date">February 10, 2018</span>
									</li>
					</ul>
		</div><div id="text-7" class="sb-widget clearfix widget_text">			<div class="textwidget"><p><a href="https://rspnutrition.com/?athletes=1599">RSP Nutrition</a></p>
<hr />
<p><a href="https://PatandEdShow.podbean.com" target="_blank" rel="noopener"><br />
<img style="width: 297px; height: 170px; border: none;" src="//d8g345wuhgd7e.cloudfront.net/site/images/top10Badges/2016/sports_and_recreation.png" /><br />
</a></p>
<hr />
<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "171563869";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUE5UR2R' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></p>
</div>
		</div><div id="custom_html-3" class="widget_text sb-widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a href="http://www.ticketmonster.com/?aid=19235" target="_new">
<img src="//dfzcfb18p6v47.cloudfront.net/images/widgets/football-300x250.jpg" alt="Ticket Monster - Cheap Tickets">
</a></div></div><div id="custom_html-4" class="widget_text sb-widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a title="DMCA.com Protection Status" class="dmca-badge" href="http://www.dmca.com/Protection/Status.aspx?ID=7d72e5d2-aa0e-496f-bcb9-12ff2ba11556"> <img alt="DMCA.com Protection Status" src="//images.dmca.com/Badges/dmca_protected_sml_120ae.png?ID=7d72e5d2-aa0e-496f-bcb9-12ff2ba11556"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script></div></div></aside></div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
		<div class="wrapper-inner clearfix">
					<div class="mh-section mh-group footer-widgets">
									<div class="mh-col mh-1-3 footer-1">
						<div id="text-9" class="footer-widget widget_text">			<div class="textwidget">Inside Football is a fully accredited, independent media organization that is neither sponsored by nor affiliated with the New York Football Giants or National Football League. Your use of this website constitutes your have read and agree to the terms and conditions outlined under <a href="https://insidefootball.com/insidefootball-com-website-use-terms-and-conditions/">TERMS AND CONDITIONS</a>.</div>
		</div>					</div>
													<div class="mh-col mh-1-3 footer-2">
						<div id="text-14" class="footer-widget widget_text">			<div class="textwidget"><a href="https://insidefootball.com/meet-our-team/">Meet Our Team</a><P>
<a href="https://insidefootball.com/frequently-asked-questions/">Frequently Asked Questions</a><P>
<a href="http://shop.insidefootball.com/">Subscription Information</a><P>
<a href="https://insidefootball.com/insidefootball-com-website-use-terms-and-conditions/">Web Site Use Terms and Conditions</a><p>
<a href="https://insidefootball.com/inside-football-llc-web-site-privacy-policy/">Privacy Policy</a><P>
</div>
		</div>					</div>
													<div class="mh-col mh-1-3 footer-3">
						<div id="text-18" class="footer-widget widget_text">			<div class="textwidget">            <a class="twitter-timeline"  href="https://twitter.com/Patricia_Traina" data-widget-id="686314172284551171">Tweets by @Patricia_Traina</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          </div>
		</div>					</div>
							</div>
			</div>
	<div class="footer-bottom">
		<div class="wrapper-inner clearfix">
						<div class="copyright-wrap">
				<p class="copyright">
					©2007-2017 Inside Football LLC. Content may not be reproduced without express written consent from the Publisher. NFL and team logos are registered trademarks, and are used under the terms of the annual NFL media credential notice.				</p>
			</div>
		</div>
	</div>
</footer>
		<script type="text/javascript">
			(function($){
				$(document).ready(function() {
					$( '.cntctfrm_contact_form .cntctfrm_error, .cntctfrm_contact_form input[name^=cptch]' ).on( 'input paste change', function() {
						$( this ).removeClass( 'cntctfrm_error' );
						$( this ).next( '.cntctfrm_help_box' ).removeClass( 'cntctfrm_help_box_error' );
						$( this ).parent( '.cptch_block, .cptchpr_block' ).next( '.cntctfrm_help_box' ).removeClass( 'cntctfrm_help_box_error' );
						if ( $( this ).is( 'input[type=checkbox].cntctfrm_privacy_check' ) && $( this ).is( ':checked' ) ) {
							$( this ).prev( '#error_privacy_check' ).css( 'display', 'none' );
						}
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box' ).bind( 'show_tooltip', function() {
						$help_box = $( this ).children();
						$( this ).removeClass( 'cntctfrm_hide_tooltip' );
						$( this ).addClass( 'cntctfrm_show_tooltip' );
						if ( $help_box.offset().left + $help_box.innerWidth() > $( window ).width() ) {
							$help_box.addClass( 'cntctfrm_hidden_help_text_down' );
						}
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box' ).bind( 'hide_tooltip', function() {
						$help_box = $( this ).children();
						$( this ).removeClass( 'cntctfrm_show_tooltip' );
						$( this ).addClass( 'cntctfrm_hide_tooltip' );
						$help_box.removeClass( 'cntctfrm_hidden_help_text_down' );
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box' ).mouseenter( function() {
						$( this ).trigger( 'show_tooltip' );
					}).mouseleave( function() {
						$( this ).trigger( 'hide_tooltip' );
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box.cntctfrm_show_tooltip' ).on( 'click', function() {
						$( this ).trigger( 'hide_tooltip' );
					});

					$( '.cntctfrm_contact_form .cntctfrm_help_box.cntctfrm_hide_tooltip' ).on( 'click', function() {
						$( this ).trigger( 'show_tooltip' );
					});
				});
			})(jQuery);
		</script>
	<script type='text/javascript'>
var colomatduration = 'fast';
var colomatslideEffect = 'slideToggle';
var colomatpauseInit = '';
var colomattouchstart = '';
</script>		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
			<div style="display:none">
	</div>
<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/insidefootball.com\/friday-5-coaching-staff-free-agency-injuries\/":6423};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/friday-5-coaching-staff-free-agency-injuries/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://insidefootball.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
			<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/platform.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
								<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<script type="text/javascript" src="https://platform.tumblr.com/v1/share.js"></script>		<script>
		// Don't use Pocket's default JS as it we need to force init new Pocket share buttons loaded via JS.
		function jetpack_sharing_pocket_init() {
			jQuery.getScript( 'https://widgets.getpocket.com/v1/j/btn.js?v=1' );
		}
		jQuery( document ).ready( jetpack_sharing_pocket_init );
		jQuery( document.body ).on( 'post-load', jetpack_sharing_pocket_init );
		</script>
		<script type='text/javascript'>
/* <![CDATA[ */
var edd_scripts = {"ajaxurl":"https:\/\/insidefootball.com\/wp-admin\/admin-ajax.php","position_in_cart":"","has_purchase_links":"","already_in_cart_message":"You have already added this item to your cart","empty_cart_message":"Your cart is empty","loading":"Loading","select_option":"Please select an option","is_checkout":"0","default_gateway":"paypal","redirect_to_checkout":"0","checkout_page":"https:\/\/insidefootball.com\/checkout\/","permalinks":"1","quantities_enabled":"","taxes_enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/easy-digital-downloads/assets/js/edd-ajax.min.js?ver=2.8.18'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201807'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=5.8'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=5.8'></script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=5.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidefootball.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=5.8'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=20171126#ver=20171126' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201807.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.8',blog:'122731363',post:'6423',tz:'-5',srv:'insidefootball.com'} ]);
	_stq.push([ 'clickTrackerInit', '122731363', '6423' ]);
</script>


 <div id="formillachat" style="z-index:100 "></div><div id="formillawindowholder"><span style="display:none"></span></div><script type="text/javascript">      (function () {       var head = document.getElementsByTagName("head").item(0);       var script = document.createElement('script');       var src = (document.location.protocol == "https:" ? 'https://www.formilla.com/scripts/feedback.js' : 'http://www.formilla.com/scripts/feedback.js');      script.setAttribute("type", "text/javascript"); script.setAttribute("src", src); script.setAttribute("async", true);       var complete = false;       script.onload = script.onreadystatechange = function () {         if (!complete && (!this.readyState || this.readyState == 'loaded' || this.readyState == 'complete')) {           complete = true;           Formilla.guid = 'csb9eb3e-bf57-4bf9-b186-2929b1c3432c';          Formilla.loadFormillaChatButton();             }      };       head.appendChild(script);   })();  </script> </body>
</html>